Impossible to login to PHPMyadmin - and other Apache sites

I suddenly lost the ability to connect or re-connect to Apache sites. The sites still work correctly, either in connected or not connected modes.

Particularly, I can no longer connect to PHPMyAdmin - it stays on the login page without any error.
There are no error in logs, the connection attempts do not even appear in the logs.
It seems that Apache - MySQL do not intereract for login - though once connected, it works mostly fine.

Any clue?

Thank for help, I am totally stuck

Uhm, can you clarify this one please? You’re talking about “connections” in as I see it several different scenarios. What does “re-connecting to sites” mean?

Also, I think your first two sentences contradict each other… If you can’t connect to sites, how are they still “working correctly”?

Please tell us in detail what you tried, what you expected and what happened instead.

Connecting - I mean

  • web sites have public and private access - The user that logs in get “connected”

Working correctly:

  • anonymous visitors can browse the web site
  • logged in users can also browse and pubish content

The problem

  • there is no way to log in once “disconnected” or logged out. I cannot login anymore to any web site
  • specifically, it is not possible to login to phpMyAdmin - the main page displays correctly, but nothing happens when submitting username and password - exactly like all web sites
  • no error log nor access information in apache2 logs.


Thank you very much for taking care

Okay, I think I get it now. With “connected” you mean “logged in” or “authenticated”.

The issue you’re seeing might be a browser problem. What happens when you try it with a different web browser? You might also try clearing the browser cache and cookies, and restart it.

I tried with IE, FF and Chrome, cleared the caches and so on - same thing.
It works correctly with another quite similar server

Any place I should look for to solve this critical issue?

So, just to clarify – it’s not just you, but all users on your server are experiencing the same problem?

Or are other users able to log into sites on your server?

If you’re able to browse to various websites on your server, but not login… and that’s a problem all users on your server are experiencing, two thoughts come to mind –

  1. I’m surprised that you’re not seeing any messages at all in the error logs, you’d definitely want to make sure you’re looking in the logs specific to the domain that’s having problems – that’s located in $HOME/logs/error_log.

  2. It’s possible that the sites aren’t communicating with MySQL. Again, that would normally show up in the error logs, but it can’t hurt to restart MySQL by running this from the command line as root: /etc/init.d/mysqld restart

I did not ask other users, I tried from different computers from home, same behaviour
It looks like mysql is never hit “directly” by my web sites. I even change the database name of one site, it still worked!

There are no error at all, the access log stopped recording anything since yesterday
I suspect some cache to bypass all requests from Apache

A simple and maybe stupid question: You did try restarting Apache, right? :slight_smile:


If all websites that have a login on your server aren’t functioning, is it normal that users wouldn’t be complaining to you?

With that large an issue, and it’s been broken for at least 8 hours now, it seems unusual that you’re the only one who’s noticed.

So, I’m suspicious that it may be somehow related to your home setup, or maybe your ISP.

What you’re describing certainly could be a cache issue… it’s possible that your ISP is using some form of caching proxy that’s causing the issues you’re seeing.

Do you have someone who can test it using a completely unrelated connection and ISP than you’ve tried so far?


After further research, I actually get Apache access info, but not when tryiong to login, and not for certain actions (like asking for a new password)

Only one site could have get soe login attempts today, but not sure. Also, they would normally not need to login again as their session is saved.

I of course restarted Apache, MySQL, and even the server several times.
I tried to kill all possible caches with no more success.

Your suggestion about my ISP might be worth exploring, because this is really puzzling

Is this something that we could test out?

Is there a URL, username, and password for some sort of test site that you could post here that we could try to see if we get the same results?


Good idea
However, I cannot create a dummy user to let you connect to the web site.
But you can at least try these 2 phpMyAdmin installed by VM on 2 different servers

entering any (wrong) login should warn “#xxx Cannot log in to the MySQL server”



On my side:

(1) behave correctly on this server

(2) keep silent on the faulty server.

Also I created a user vmt/vmt that has permission for a useless database “cases” - you should be abale to connect to using this login

Thanks a lot

Yeah, I’m seeing the same results you are… I do receive a “Can’t login” message on the first link, and when using the user information you provided on the second url, it returns to a blank screen with no error message.

Did that phpMyAdmin install every work correctly?

And, did you say you’re seeing similar problems with other web app logins on your server?


The second server fails for me as well, there’s no error message or other comment upon login, no matter if I enter nonsense or the correct username. I’m simply taken back to the login screen.

Is the “1” after the second URL correct? Does phpMyAdmin maybe have some local configuration where you need to enter its URL path? Does it match the URL you’re using?

Does this help maybe? The following post describes an issue with php session variable directory.

Otherwise, I’d suggest thoroughly comparing the Apache and PHP settings on the working and failing servers, including PHP execution mode (mod_php vs. FCGI), the suexec settings and file access rights (ownership/permissions).


  • yes, the “1” in is correct

  • phpMyAdmin was installed using VM script installer in both cases. I tried to reinstall several times, it proceeds normally. It used to work, but not anymore

  • I checked the session.save_path issue, tried several configs. What I found is that the directory was empty, but 300K size. I deleted the directory and rcreated it, I also changed the location of this path, but without any effect after restarting Apache, and even rebooting the server.


Every app I need to login through Apache / php fails. I can connect to VM without problem, but cannot do anything with my web sites runing Apache / php, including phpMyAdmin as discussed just above.
The sites I am logged in keep as is until I log out - then I have no way to login anymore.

Looking at both servers PHP information, I found that: checking phpinfo on the phpMyAdmin welcome screen, the variable HTTP_COOKIE contents this:

  1. failing server

phpMyAdmin unlogged
SESS9e15b58ce905bc905f72910fd9ae69ab=6c4f07f435d9c90241f164a3838e9dd0; has_js=1; __utma=73559177.1425389158.1312879513.1312879513.1312879513.1; __utmb=73559177.2.10.1312879513; __utmc=73559177; __utmz=73559177.1312879513.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

Another web site unlogged
SESS9e15b58ce905bc905f72910fd9ae69ab=6c4f07f435d9c90241f164a3838e9dd0; has_js=1; __utma=73559177.1425389158.1312879513.1312879513.1312879513.1; __utmb=73559177.2.10.1312879513; __utmc=73559177; __utmz=73559177.1312879513.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

(all my sites are unlogged now, as I emtied my browsers’ caches :()

  1. correct server

phpMyAdmin unlogged
phpMyAdmin=hrf0t84o0m545lp7b22g25hv1h28g5hi; pma_lang=en; pma_collation_connection=utf8_general_ci; pma_mcrypt_iv=iyD0j%2BI9cVw%3D

phpmyadmin logged
phpMyAdmin=g0l517u3kdg01ogtqo9o322th49is5r3; pma_lang=en; pma_collation_connection=utf8_general_ci; pma_mcrypt_iv=iyD0j%2BI9cVw%3D; pmaUser-1=vDlyo%2BCmVWk%3D; pmaPass-1=U1fA7eleX6o%3D; has_js=1; SESS384300a1104195dd3b58ab2f046bb319=3L6xB2QzMjVoZhwoVrxTosP3FKdO4y55rC_9lRvf0dE; Drupal.toolbar.collapsed=0

Another web site unlogged

the same, logged
has_js=1; SESS384300a1104195dd3b58ab2f046bb319=3L6xB2QzMjVoZhwoVrxTosP3FKdO4y55rC_9lRvf0dE; Drupal.toolbar.collapsed=0


Did you compare the configuration for Apache and PHP for the two servers thoroughly? There has to be SOME difference if the systems are otherwise the same.

They both were installed by Webmin / Virtualmin, though the failing one was updated with dotdeb for upgrading Mysql to 5.1 - php upgraded to 5.2.17 at this moment.

Apart of phpinfo,



what should I look for?

thanks again

Well, what you’re describing there all sounds very bizarre.

I’m curious, can you access MySQL from the command line?

For example, if you log into your server as root over SSH, and then run:

mysql -p

Enter your root password when prompted… do you then get to the MySQL shell? Or is there an error of some kind?

Do you know of anything on your system that may have changed prior to all these problems occurring?


1 Like