Import from webmin

I have a domain that exists under webmin but not under virtualmin. How do I get virtualmin to import it?


If you have a domain setup on your server, but it’s not yet in Virtualmin – you can import it by going to Add Servers -> Import Virtual Server.


It sounds like there could be an IP address mismatch somewhere in the Apache config – take a peek at the section labeled “The wrong site shows up” here and see if this helps:

I did the import and now all other domains have disappeared from virtualmin and webmin.

Moreover, even the imported domain ends up using the default configuration. I cannot find any traces in any log files of accesses happening for any domains. They all just end up going to /var/www without any logging anywhere – even though 000-default has “CustomLog ${APACHE_LOG_DIR}/access.log combined”.

To top it off, the only “server” available under webmin is mail. Apache is gone from Webmin so I have to restart it from /etc/init.d

As per your link, I changed all occurring of “*:80” to “the host ip address:80” which at least got error log messages showing up. But now they’re saying there is a suexec probem “command not in docroot”.

In addition to all of my domains disappearing except for the imported one, the pointer: “It is likely to be found in the Virtualmin Module Configuration under the Other Server Settings category.” is of no use to me because most of the virtualmin UI options have disappeared:

Virtual Server Details
Edit FTP Users
Server Configuration
Change Domain Name
Change Password
Administration Options
Disk Usage
Excluded Directories
Re-Send Signup Email
Logs and Reports
Check Connectivity
Webmin Modules
Change Language and Theme
Change Passwords
File Manager
Protected Web Directories
Running Processes
SSH Login
Scheduled Commands
Scheduled Cron Jobs
List Virtual Servers
System Information

Indeed, Webmin options have been reduced to just:

Login: root
Change Language and Theme
Change Passwords
Running Processes
Scheduled Cron Jobs
Virtual Email
File Manager
Protected Web Directories
SSH Login
Un-used Modules
Scheduled Commands
System Information

I just found out that another sysadmin had reinstalled/upgraded virtualmin.


If the interface you see when logging in is logging wildly different than what you’re used to seeing – I’ve seen some cases where the Virtualmin theme manages to get unset.

If that’s the case, you can fix that by going into Webmin -> Change Language and Theme, and setting the theme to use the “Virtualmin Framed Theme”.


I found out that the sysadmin did an upgrade of software packages within webmin. Since this is a Debian 6.0 system and support has been unavailable until very recently (ie: a week ago) I thought it might be possible to uninstall the virtualmin that got upgraded and reinstall it using some specific instructions for Debian 6.0 that isn’t fresh.

However the post wherein that line was posted:

Ends with:

“Or, wait a couple of days, and I’ll have a script that will do this for you, and it will have been tested and confirmed to not create a steaming pile of wreckage.”

None of the comments indicate such a script has become available yet.

No change after:

apt-get remove virtualmin-base
apt-get autoremove
vi /etc/apt/sources.list (lenny -> squeeze)
apt-get update
apt-get upgrade
apt-get install virtualmin-base

Yeah, the virtualmin-base package doesn’t really do much once Virtualmin has been installed… it’s just a meta-package used for pulling in other dependencies.

Now that the theme has been straightened out – can you clarify what issues you’re still seeing?


Screenshot: nonrootvirtualminuserthatdidtheaptupgradefromwebmin
Shows: First page after login by non-root virtualmin user, but with the Servers dropdown expanded. This user is the one that did the software package upgrade within webmin. Its theme has been specified as “Virtualmin Framed Theme” with the “personal choice” radio button specified. For some reason the virtualmin frame is still not shown and the first page after login is Webmin.

Screenshot: rootvirtualminuser
Shows: First page after login by root virtualmin user.

Screenshot: rootvirtualminuserwebminservers
Shows: Same session for root virtualmin user but with the Webmin frame active and the Webmin Servers dropdown selected.

Obviously, I’m loath to use VM or WM at all in this state.

OK, this is kinda awesome. If this happened in a reasonably recent version of Virtualmin, this is a bug that’s been around for years, without us being able to reproduce it (a couple variations of this bug have been fixed, but I think this is a new path to triggering it).

When you did the import of the domain, you set the owner to “root” (or perhaps the domain being imported had a directory owned by root, or something). This made “root” into a regular non-privileged Virtualmin account, which has the effect of making everything else in Virtualmin “disappear”. But, it’s really that root is now a domain account holder, as far as Virtualmin is concerned.

Virtualmin shouldn’t allow you to do that under any circumstance…it doesn’t make sense to have “root” be the owner of a specific virtual server (as “root” should own all virtual servers, but doesn’t have any ownership explicitly set).

I’m pointing Jamie to this conversation because it is, I believe, the final nail in the coffin of the “root becomes Virtualmin user” bug.

The fix is to login, as root, from the command line, and edit /etc/webmin/webmin.acl to read:

root: acl adsl-client apache at backup-config bacula-backup bandwidth bind8 burner cfengine change-user cluster-copy cluster-cron cluster-passwd cluster-shell cluster-software cluster-useradmin cluster-usermin cluster-webmin cpan cron custom dfsadmin dhcpd dnsadmin dovecot exim exports fdisk fetchmail file filter firewall frox fsdump grub heartbeat htaccess-htpasswd idmapd inetd init inittab ipfilter ipfw ipsec jabber krb5 ldap-client ldap-server ldap-useradmin lilo logrotate lpadmin lvm mailboxes mailcap majordomo man mon mount mysql net nis openslp pam pap passwd phpini postfix postgresql ppp-client pptp-client pptp-server proc procmail proftpd pserver qmailadmin quota raid samba sarg sendmail sentry servers shell shorewall smart-status smf software spam squid sshd status stunnel syslog-ng syslog tcpwrappers telnet time tunnel updown useradmin usermin vgetty webalizer webmin webminlog wuftpd xinetd virtual-server virtualmin-svn virtualmin-dav virtualmin-awstats virtualmin-registrar virtualmin-htpasswd virtualmin-mailman ruby-gems security-updates virtualmin-init php-pear package-updates system-status backup-config change-user usermin webminlog webmin servers

From there, you can browse to Webmin>Webmin Users>root and edit the Virtualmin privileges to grant root access to everything again.

And, most importantly: Don’t panic! Everything is cool under the hood. Virtualmin is just confused about what root should be able to do.

BTW-What version of Virtualmin were you running when the import occurred? If it was a really old version, then this bug has probably already been fixed. I’m still going to ask Jamie to look at the thread, just to be sure it’s fixed. It’s a cosmetic issue (no data loss should actually be happening), but it terrifies users who don’t realize what happened.

I’m embarrassed to admit that Virtualmin’s domain import code doesn’t prevent you from using root as the domain owner’s login, which can cause this problem :frowning: I will fix this in the 3.84 release …

Your fix got root’s Webmin options back but the virtualmin options are still restricted.* Perhaps the restriction is to the GPL options due to the loss of license credentials during the apt-get upgrade?

*For example, install scripts available.

See attached screenshot: rootvirtualminuserstillhozed

See screenshot rootvirtualminuser

You missed the last step. You need to browse to the Webmin Users module, and re-grant the root user access to everything in Virtualmin.

I was here:

Edit Webmin User
Webmin user access rights
User interface options
Security and limits options
Available Webmin modules
Permissions for all modules

The only place the word “virtualmin” appeared was under “Available Webmin modules”. All of those options were enabled. If you mean “Permissions for all modules”, the word “virtualmin” did not appear there.

See the attached screenshot rootwebminuserpermissions

Sorry I didn’t really make the process clear…You’re in the right vicinity but missing a step:

In the Available Modules section, click on Virtualmin.

Then, at the bottom of the page, click the “Reset to full access” button, which should make your user a “root” level user again, in the eyes of Virtualmin.

If that doesn’t do it, we may need to login and have a look, as I can’t think of anything else that’d be needed to recover from this problem (but it’s been a year or two since we’ve seen it, so I may have forgotten something).

It appears we are back on track.