Import failure from one virtualmin to another "could not work out the default IP address ..."

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.994
Virtualmin version 7.1-1
Related packages Network / DNS

Hello there

I have an issue with a backup virtualmin installation. When I import a backed up virtual server from my production server, which is a vps, i get the error message:

Checking contents of the backup …
… found 1 virtual servers

Starting restore of 1 domains from local file /home/Bkp/restore …

Extracting backup archive files …
… done

Re-creating virtual server
… could not work out the default IP address

… failed! See the progress output above for the reason why.

Both servers have the same software configuration. The backup server is in a DMZ of a firewall and its IP is from the local DMZ and not from the wide web. I can reach virtualmin on the backup server with no problems since I setup the NAT an security service of the firewall. I have made a domain for this backup server and placed it as virtual server of the virtualmin instance. I don’t know yet what will happen when the ISP changes the IP of my router. But this is another problem since virtualmin doesn’t offer dynamic IP’s other than DynDNS, which is a pity.

Thanks for reading it to this point. Any help is greatly appreciated.


Help Virtualmin to get server’s IP address by setting it manually on System Settings ⇾ Virtualmin Virtual Servers ⇾ Configuration: Networking settings page.

Hi Illa,

Thank you very much for your response and effort. Unfortunately there is no success yet.
I gave Virtualmin that little help and put in the same IP as is bound by the network interface. It is a local IP from the DMZ. On my production server that IP is an official dedicated IP. So I wonder if I have to change the IP of my backup server to an official one. I actually tried to do that, but my efforts are so fare neglected by Virtualmin.
What do you think?

Is there anybody out there?

It can be, that we are dealing with a bug here.

I tried follow scenario: I generated a new virtual server and backed it up to the backup server. There I made an import of the vs and everything worked fine.

Next scenario was: I generated first the vs on the backup system and then imported the vs from the production system. This szenario works almost fine. I have problems do start wordpress which might be an indication of configuration faults.

My question now: What exactly triggers the message “could not work out the default IP”?

It was a matter of proper IPv6 configuration from the router to the DMZ and into webmin/virtualmin.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.