import domain breaks some, fixes others

Summary: Import a domain name first, break the layout and visuals of the virtualmin module, but everything else works great. Add a domain name first, layout and visuals are great, sub-servers create their own master zone file rather than being added to their parents zone file.

This is odd, and I’m still not convinced it isn’t coincidence. I have tested this theory a minimum of 20 times on two different servers. Both servers were running Debian 4. The first issue is (and i can also verify this part exists on CentOS) if after a good installation from .deb, .rpm, or by using webmin to install the .gz, if you ADD a domain first, the function to add sub domains (sub servers) to that same zone fails to function properly. For example, i start off with a clean install and ADD, owned by… so far so good. Then I add with as the parent, and owned by This should simply add another line to the zone file that points to its proper place as an A name. It does not, it creates a new zone file

This is where it gets complicated, and the rest is only verified on Debian 4.

If i start with a clean install and the first thing i do is import any existing domain… lets say, then things are really strange. I am unable to get a server list, all the icons from the main virtualmin page are gone, and I have only a small 2 line form with an "Add new virtual server, owned by" button, a list to choose owner including <new user>, an "import virtual server" button, and a "migrate virtual server" button. Also there is a "return to previous page" link. Obviously this is not the correct operation, there is no list of servers, there is no icons, and even using the virtualmin theme, when i click server list, there is no list… however…
it functions perfectly otherwise. The subdomains are added to their parents zone file properly, all domains work.

Sorry this is such a long read, but its a quite confusing problem and I would like some help testing to verify this is in fact really happening this way.

*** I have attached a screenshot that i have trimmed down to be smaller, but still include all relevant info, as well as edited only to remove private info. This is the "import first" type screenshot ***<br><br>Post edited by: daerious, at: 2008/03/04 17:47

Here’s the screenshot… I hope… sorry

I haven’t had a chance to parse out exactly what problem you’re describing or attempt to reproduce it, but I have the immediate question of: Why aren’t you using the Virtualmin Framed Theme? Without it, Virtualmin is pretty much crippled hopelessly.

I have tried using the virtualmin theme as well… This is a screen shot after I have clicked "List Virtual Servers". The drop down menu does contain the servers, but they are not listed on the main page, nor is any of the configuration options…

Even with the virtualmin theme, if i import a domain before i have added a new domain, it goes goofy. After more testing along with the help of some friends ;), it is frustratingly random now as to the way it adds sub servers. If i add a domain first, the pages always look correct, with the list of servers and all, however it never adds sub servers the way it should ("should" based on reading documentation and forums). If i import a domain first, it always messes up the screen but seemingly randomly will add sub servers correctly, or in their own zone.

did you ever get this figured out? I’m having the same issue. i can’t get into the virtualmin anymore.

Looks like a bug. I’d recommend filing it in the tracker so Jamie can get it fixed. Assuming you’re running the latest version of Virtualmin, of course.