IMAP errors and mass user creation errors

Hey I would appreciate any help for these things.

  1. So I created a virtualmin server running on a vultr debian 10 system. I have everything set up and I can create users manually. The domain i have setup is ([] and I can log into the emails from squirrelmail or roundcube but thats it. Id like to be able to acess the mailbox via IMAP but I am unsure what setting to use. I read other fourms and they say “” work and I tried “” for me as the imap server it does not appear to work. I have also tried as the imap server but nothing works. Is this possible to do or can I only access the mail via squirrelmail. I am unsure how to get my server to work with imap. Not sure how to get that sorted out so I could use other mail clients that rely on imap and smtp servers.

  2. I would like to add bulk users. There is a documentation for this but it does not seem to work for me. It says this is the format (username:realname:password:ftp-flag:email-flag:quota:[extras]:[forwards]:[databases]) and this is what ive tried,


but it says that “Error on line 1 for bot02 : Database does not exist in this domain”. However if I go to the edit databases it is a database.

Any help is appreciated here as I am starting to get lost.

Hello @Xeon and welcome to the community.

You should be able to get POP, SMTP and IMAP on an email client if you create a subdomain ‘mail’ and point it to the IP address of your Virtualmin server.

Oh, you probably have databases disabled by default for new virtual servers. Edit the virtual server and enable the database for the domain by clicking on the appropriate check box under the tab captioned Enabled Features.

Thank you for your response!

I tried this and appears to now exist; however still not working as an imap, pop, or smtp server. Photo of Thunderbird attempting to login -
Photo of the dmain settings -

It appears this setting was already checked in the virtual server domain settings. Is there another place I should check or is this not the right place? One again any help is appreciated!

I see you are using port 143. You could try 993. Everything else looks good for email.

You could try leaving the password parameter set to null.

The solution was to not use SSL/TLS or STARTSSL but to use none. This was due to not having an SSL certificate. One I installed one using SSL/TLS worked fine (go figure). Thanks for helping with that problem. As for this…

Could you please provide an example of what to do for mass email creation? The example virtualmin gives is


what would this look like all filled out?








Have a look -

This worked for me thank you again for all your help,

I did not know this page existed. Cheers

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.