ImageMagick on Centos 7

Hi,
I’ve installed ImageMagick on my system with Centos 7 and on command line if i try this command:
convert --version
Version: ImageMagick 6.9.10-68 Q16 x86_64 2020-12-15 https://imagemagick.org
Copyright: © 1999-2019 ImageMagick Studio LLC
License: ImageMagick - License
Features: Cipher DPC Modules OpenMP(3.1)
Delegates (built-in): bzlib cairo fontconfig freetype gslib jng jp2 jpeg lcms ltdl lzma openexr pangocairo png ps rsvg tiff wmf x xml zlib

But if i check with phpinfo() the ImageMagick isn’t active.

Thanks in advance.
Ika

Do you have the PECL extension installed for the version of PHP you’re using?

Richard

ImageMagick is a C library, it is not a PHP library/module/extension/whatever.

If you expect ImageMagick functions to be available to PHP, you need the PHP extension that binds to the C library in addition to the ImageMagick package. php-pecl-imagick is probably what you want, but if you’re using php72, you’ll need the package for that version, php72-pecl-imagick.

I’ve tried to install the package php72-pecl-imagick but the system doesn’t find the package.

Yes of course, i’ve installed PECL. :slight_smile:

After a reboot works fine :slight_smile:

A reboot wasn’t necessary. You just needed to restart either the httpd or php-fpm service.

I know, but only with reboot i’ve solved this issue and work fine.