ImageMagick installation

Hullo, all!

This is a real newbie question for you:

I wish to install ImageMagick in an existing Virtualmin context. Is there a standard protocol for this? (ie. directory locations, manual edits to ini files, etc.)

CentOS Linux 6.9
Webmin version: 1.844
Virtualmin version: 5.99
Kernel and CPU: Linux 2.6.32-696.1.1.el6.x86_64 on x86_64
PHP version: 5.3.3

Please advise.

Thanking you in advance!

So, I decided to install to the directory:


My install stops at the line below. Any thoughts as to the problem? I have tried rewriting the directory path in config.m5, but I’m really vague on where that path should lead.

I’m a programmer, not a server guy. Any help is appreciated.

checking for grep that handles long lines and -e… /bin/grep
checking for egrep… /bin/grep -E
checking for a sed that does not truncate output… /bin/sed
checking for cc… cc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether cc accepts -g… yes
checking for cc option to accept ISO C89… none needed
checking how to run the C preprocessor… cc -E
checking for icc… no
checking for suncc… no
checking whether cc understands -c and -o together… yes
checking for system library directory… lib
checking if compiler supports -R… no
checking if compiler supports -Wl,-rpath,… yes
checking build system type… x86_64-unknown-linux-gnu
checking host system type… x86_64-unknown-linux-gnu
checking target system type… x86_64-unknown-linux-gnu
checking for PHP prefix… /usr
checking for PHP includes… -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib
checking for PHP extension directory… /usr/lib64/php/modules
checking for PHP installed headers prefix… /usr/include/php
checking if debug is enabled… no
checking if zts is enabled… no
checking for re2c… no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk… gawk
checking whether to enable the imagick extension… yes, shared
checking whether to enable the imagick GraphicsMagick backend… no
checking ImageMagick MagickWand API configuration program… configure: error: not found. Please provide a path to MagickWand-config or Wand-config program.

I presume you followed this?

I certainly have — at least the same procedure, posted by others. This particular iteration (Srain’s page) also includes the path to the php-config file, which I altered to match mine (/usr/bin/php-config)

I still get the same error, and I am attempting to use these instructions here to redirect the path to the ImageMagick config file “magickwand.h”.

Here are some of the paths I have tried in the config.m4 file:

if test -r $WAND_DIR/include/ImageMagick-7.0.6-0/MagickWand/MagickWand.h; then
		if test -r $WAND_DIR/include/ImageMagick-7/wand/MagickWand.h; then

		if test -r $WAND_DIR/include/ImageMagick-6/wand/MagickWand.h; then

		if test -r $WAND_DIR/include/ImageMagick/wand/MagickWand.h; then

What am I missing?

Not having used this myself, I will read through your comments and check if I can see anything obvious.

Having read through some of the comments on one of the posts, have you tried this option yet?

yum install ImageMagick-devel

Yes, indeed. This demanded an update of php, however; and that bolloxed my set up. Once I figure out where my php5_module file went, I will let you know how the ImageMagick install went :stuck_out_tongue:


Thank you for following up on my progress.


Follow up note: this is all working well since I updated to PHP 5.4.45.

Thanks again for your help.