Identifier removed: mod_fcgid: can't lock process table in pid 20735

Hi there
I’m getting “Identifier removed: mod_fcgid: can’t lock process table in pid” error log my memory usage is high and server unusable please help me out here.

Thank you


What distro/version are you using?

It sounds like it’s a bug in FCGID.

One workaround appears to be to perform a full restart of Apache on occasion.

Alternatively, you could switch away from FCGID, and use CGI instead. You can change that by going into Server Configuration -> Website Options, and changing the PHP Execution mode from FCGID to CGI.


Virtualmin version : 3.94.gpl GPL. almost 400+ running processes this never happen to me before, out of 2GB almost 1.78GB used and my site is not even online.


That looks like your Virtualmin version, not your Linux distribution and version. Which Linux distribution is it that you’re using there, and which version is that?

You can determine that by running this command:

cat /etc/issue

Oh i’m sorry i just dnt know much bout this, i’m using Debian 6.0 Squeeze (64bit) i cannot enter command i think it doesn’t accept my password

after switch to CGI i reboot my system and came up with this error

Hi there,
I did change to CGI but nothing change. i get so many running process and it eatup my RAM please any help would be great


I did change to CGI but nothing change.

Well, you should no longer be receiving the FCGID error if you’re not using FCGID. If you’re still receiving that same error, some domains may still be using FCGID.

i get so many running process and it eatup my RAM please any help would be great

However, if you’re just having a problem of too many processes running, that’s a different issue… that may mean that you’re dealing with one or more of the following:

  1. Apache and/or PHP may each be using too much RAM per-process

  2. You may be receiving more requests at a time than your server can handle

  3. Your application may be taking too long to execute

There’s some tips on solving issues #1 and #2 in the documentation here:

But essentially, you’d want to make sure that Apache and PHP are using as few modules as possible… and you’d also want to tweak Apache to limit how many processes it can run at a time.

You also may want to test your application to make sure it’s running optimally… if one or more pages in your site take a particularly long time to load, it could cause Apache and PHP processes to stack up.


Hi there,
When i check my running process i see so many " /usr/sbin/apache2 -k start" and " /usr/bin/php5-cgi" running and i can see more eache takes 281480 kB ram. when i stop apache they stop running… i’m sorry but i need ur help please.

This is a documented bug in FCGID. It was solved with 2.3.7. See

how do i apply this patch please can you help me

upgrade to the latest version of mod_fcgid available for you.

I am still experiencing the problem with mod_fcgid 2.3.9 and apache 2.2.15. Graceful apache restarts leaves php processes dangling. This was suppose to have been fixed in 2.3.7 (