I think suExec is not working anymore ...


I have upgraded my server from Debian 5 to Debian 6, and of course apache/php/mysql have been updated in the process.

No major update for apache, but php 5.2 has been updated to 5.4 (DotDeb) and MySQL from 5.1 to 5.5.

Now my websites (mostly Wordpress) can’t update or create files. I now have to give ownership to all files to www-data user to do that.

I tried to put www-data in my current user group, and my user in www-data group instead, but it didn’t work.

As a test, I have set up a new virtual server on a new sub-domain. The user of this server is “test”
I tried to install Zenphoto CMS, all the files created during the process have “www-data” as owner and group.
I was expecting files being created with “test” as owner and group …

If I understood it right, webmin/virtualmin is configured to run PHP as an Apache module, but use suExec to be able to run scripts under user accounts.

I have no new log in /var/log/apache2/suexec.log since the update.

What can I check/change to make it work again as before … ?



There are a couple of things that could occur after an upgrade to cause that… if you go into System Settings -> Re-Check Config, does it notice any problems? I suspect it might see an issue with the mod_php config, which is just a matter of commenting out a couple of lines. But it will explain how to do that if that’s indeed the case.

Let us know if that does the trick!