I seem to have broken SSH access to my server?

Operating system Ubuntu Linux 18.04.6
Webmin version 2.013
Virtualmin version 7.5

SSH access is provided by password.
I was able to access my server this morning (using SQLYog).

I tried to give a user SSH access by going to Webmin/System/Users and Groups/ and added the user to the SSH group in Secondary Groups.

Since then, the SSH server is not responding.
If I try to open a session with Putty it times out, no option to enter a user name.

I have reversed my action, and restarted the SSH server, but still no SSH response from the server.

I can still login to my server via Virtualmin, as root.

Can anyone offer some suggestions?

ssh -v might give a clue as to what is happening.

From the webmin terminal:
root@test:/var/log# grep -r ssh * |less


ssh -v doesn’t seem to be an option?

I don’t seem to have any ssh logs?

Anyway, I rebooted and after about half an hour it seems I now have SSH access again?

I wonder if I somehow blocked access from my IP address?

I was trying to login as a user and got rejected, which is why I wanted to make sure that they had SSH access.

I’ll see if I can find a way to check if a user has ssh access, and how to grant a user ssh access via terminal - the only methods I can find for doing it via Virtualmin don’t seem to be working.

I’m new to this software but look at fail2ban. I’m not sure what the defaults are but that is what the software does to prevent brute force attacks.

Thanks, I will.

That’s fail2ban.

You entered the wrong password several times (five, I think, is the default).

If you use key-based authentication you’ll never have that problem (and it’s stronger than a password that a human can type could ever be). You could also alter the fail2ban configuration to be more forgiving of wrong passwords, but then you reduce the effectiveness of fail2ban at preventing brute force attacks.

Yeah, thanks Joe

I’ll see what I can do with key authentication.