I have changed the webmin port, but I cannot access.

I installed the latest version of virtualmin over ubuntu18, I need to use port 2096.
I did different tests but I can’t connect even when I try to use port 10001, please help me.
I made the port change from the webmin web interface and also from the Ubuntu 18 Linux console, I also opened the port in the firewallD, I am only able to connect when I configure the 10000 port.

port = 10000
listen = 10000
service webmin restart


All help and suggestions are welcome.
Thanks in advance

Its either firewall issue or not restarting webmin issue. I change from 10000 to something else all the time.

Add 2096-2107 to firewall allow. Change webmin listen port to 2096. Restart webmin. See if can connect to 2096. If works, disable 10000-10011 in firewall.

Believe me that I have tried anyway, can you please change the port and verify what I am doing wrong?
Thanks in advance.

host SSH:
User webmin or SSH: ****
Passwordwebmin or SSH: ****

OK, I tried. You’ve got something else firewall wise going on. Is this hosted on Amazon or GCC where you also need to open firewall ports with their firewall?

I change webmin port, it was already open in firewalld, no go. Disable firewalld, no go. So something else is blocking that port. Since it just sits there not responding, its a firewall issue. Not with your VM but elsewhere up the line. If this is a dedicated or you are directly connected to the net, then Im lost and never had this happen. Delete that user asap BTW.

Further investigating and that is a GCC ip so Im sure they have that port firewalled as well.

Thank you so much and I am so sorry.
I forgot to open the new port in Google Cloud, now I did it, and everything works perfectly.
Thank you very much for your time you are my hero :slight_smile: