I have a virtual server in Virtualmin that does not show in Webmin

OS type and version Ubuntu 18.04.6 LTS
Webmin version 1.994
Virtualmin version 7.1

I am running Ubuntu and Webmin and Virtualmin on hardware from Vultr. I had a number of problems that I will not detail here. Hopefully I will give a salient description for help.

I have 2 virtual servers running on Virtualmin. At the beginning, Apache was not running. I tried to restart it and it gave me a hint.

Jul 14 12:59:22 systemd[1]: Starting The Apache HTTP Server…
Jul 14 12:59:22 apachectl[2842]: AH00526: Syntax error on line 100 of /etc/apache2/sites-enabled/comprehensionengineering.com.conf:
Jul 14 12:59:22 apachectl[2842]: Invalid command ‘php_admin_value’, perhaps misspelled or defined by a module not included in the server configuration

I found the configuration file it mentioned, and I searched for the problem. I found reference to removing the php_admin_value line if I did not not have mod_php running? I think? I got rid of the line and now Apache would start.

Now one of the two websites shows up in Webmin/Apache.

Here is the view of Apache from Webmin.

And now the view of the two servers in Virtualmin
pretend there is a screenshot here (a newbie limitation I guess).

When you try to http to either server, it shows up at the Caldwellfarms website.

I have looked many places for a switch or configuration file to turn on the comprehensionengineering website. In Webmin there is a place to create a new virtual host.
pretend there is a screenshot here (a newbie limitation I guess).
but I am afraid I could really mess things up this way.

Please help.

Have you run Re-Check Configuration?

Thank you for the tip. I ran re-check and I found this abnormal result.

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the [module configuration]page.

On looked on the module configuration page. It uses the default IPv6 value. I am not skilled enough to know if that is wrong.

Thank you for your help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.