I Can't Give Remote Access to MariaDB

OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Usermin version 1.860


I have a project whose database resides on the server. To develop project on localhost, I need to grant access via Virtualmin, but I can’t!

I tried the following:
Webmin Tab > Servers > MariaDB Database Server > MariaDB Server Configuration > MariaDB server listening address > “any” selected > Save and Restart MariaDB
This didn’t work.

Virtualmin Tab > Selected the Related Domain > Edit Databases > Remote Hosts > There was only “localhost” and I added “%”. > Save

That didn’t work either. I cannot access remotely.
What else can I do?
How can I find out what is blocking it?


Have you created a firewall rule to allow access from remote server to port 3306?

*** Professional, Affordable, Trusted Technical Assistance – https://tpnassist.com ***

1 Like

Me too I need remote access to MySQL in a similar setup to yours.

I read and applied most of the related topics I found here without any success :frowning: most of the topics are old and very few marked as resolved.

I hope someone would come up with a clear solution. :pray:

Maybe that should be %.%.%.%? Have you tried the remotes IP not wildcards.
test port https://portchecker.co/ is open

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.