I can't access :20000, admin.domain...

Hello. I was looking for some post with the same problem, but I couldn’t find.
I’ve set a virtualmin with 2 virtual servers right now. They-re all working fine. I’ve installed the roundcube in one of them and the emails are ok (sending and receiving).
Nevertheless, I can’t access the emails by usermin, for example. And it seems I can’t access mail.domain, webmail.domain, admin.domain and so on.

I’ve re-check the configuration and I just got a message:
Default IP address is set to, but the detected external address is actually This is typically the result of being behind a NAT firewall, and should be corrected on the module configuration page.

I’m using a VPS from AWS. I left the IP if you think it’s necessary to help me out.
Could anyone help me? I’m sorry, I’m really newbie and my English isn’t that good…


I don’t actually seem to be able to access port 20000, even when going directly to the IP… is Usermin running?

You can verify that by issuing a restart to the Usermin process like the following:

/etc/init.d/usermin restart

Once you do that, are you then able to access Usermin?


Thank you for your really fast reply.
After I restart the usermin that problem was solved.

Nevertheless, I still have problems to access mail.patrickmacedo.com.br, for example.
It works fine when I try to access patrickmacedo.com.br… Any idea about what could be the problem?

The domain “patrickmacedo.com.br” seems to be handled by servers named “a.sec.dns.br”, which indicates you’re not using your Virtualmin server for DNS but an external one.

Those reply “NXDOMAIN” for “mail.patrickmacedo.com.br”. I guess you did not properly configure that external nameserver hoster to handle your subdomains?

Thank you for your help. I saw that the problem was in the “a.sec.dns.br”, which is the dns server from Brazilian registrar.
But I think I have to research more regarding all linux stuff. I tried to resize the linux partition after growing my AWS volume and now I can’t use the instance (probably I did some stupid thing during the process).

Well, thanks for your help and I’ll try to use virtualmin again another time, after getting more used to all this linux server stuff.

See you.