I broke clamav-daemon

On a Debian 5 server I was getting the following error in my logwatch reports on a daily basis:

Last Status:
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.95.1
DON’T PANIC! Read http://www.clamav.net/support/faq

so I followed the URL listed above and followed the instructions, but went a step too far…

I upgraded to the latest stable version but I still get the message Your ClamAV installation is OUTDATED, why?

* Make sure there is really only one version of ClamAV installed on your system:

[code:1]
$ whereis freshclam
$ whereis clamscan
[/code:1]

* Also make sure that you havenâ

have you tried apt-get clean or autoclean??

Sure did Wayne, clean didn’t do anything notable… but the autoclean removed every perl library, postfix, virtualmin, apache and much much more. I was able to get them all back and running with the install.sh but clamav is still not functioning. I hosed it good! :frowning:

Thanks for asking!

The clam folks have become ridiculous

You haven’t told us how you actually upgraded clamav. I would recommend the volatile repository for Debian. Installing from source is generally a horrible idea.

Hi Joe, I’m sorry, I installed it from volatile using apt. I’m thinking that if I can find the same version file on another server I can plop it in place, change the permissions and create a symbolic link to it?

I would file a bug with the Debian folks rather than trying to hack it into working.

10-4
Thanks for the advice! And, what is more… thanks for the best tool I’ve ever used.

Virtualmin is fantastic. What a work saver. Every day I spend with it brings something new OR relieves painful tasks.

OK, running:
aptitude to reinstall libclamav has resolved the problem I created and brought me back to the original issue with my clamav being out dated so I’ll search elsewhere for that info.

Thanks again!

We love to hear that kind of thing. You know I want to quote you on that. I’ll email you for permission to include you in our testimonials quote file (which is what generates those quotes at the top of every page). :wink: