I assume it still doesn't work for Centos 8

Although I have managed to finish the installation by going to webmin, when it tells me that Virtualmin has not been checked, I tell it to check it, and every time it says something is missing, I ask it to install it … Virtualmin gives problems; It keeps asking me for post-installation, but it hangs when I indicate “next”, it has let me create domains, but no, subdomains … I know it hangs for many things … Any ideas?

You’ve gotta show us the real errors rather than “says something is missing”. What is “something”!?

Anyway, the installer is expected to work on CentOS 8, and has been working reasonably well with only occasional error reports for months.

In short: I suspect you had errors during the installation. Those are the important ones we need to see…every problem you see after an installation with errors comes back to the installation problems. So, we need to know what, exactly, failed during installation. You can’t ignore errors in the installation.

1 Like

Is CentOS barebones before running the install script? There should be no BIND, no web server, no services at all. Did you run dnf update before installing Virtualmin? The install script and post-install works well if the server is prepped right.


Installation sequence
Installation Centos 8 (OVH)

sudo dnf update
Last metadata expiration check: 0:04:01 ago on Sun 25 Oct 2020 07:44:42 AM UTC.
Dependencies resolved.
Nothing to do.

sudo dnf upgrade
Last metadata expiration check: 0:04:34 ago on Sun 25 Oct 2020 07:44:42 AM UTC.
Dependencies resolved.
Nothing to do.
[centos@vps-c2f862bd ~]$

dnf install perl -y … Complete!
dnf install wget … Complete!
wget http://software.virtualmin.com/gpl/scripts/install.sh … Complete!

sh install.sh --bundle LEMP
[INFO] Started installation log in /root/virtualmin-install.log

▣□□ Phase 1 of 3: Setup
/usr/sbin/setenforce: SELinux is disabled
Downloading virtualmin-release-latest.noarch.rpm [ :heavy_check_mark: ]
Installing virtualmin-release package [ :heavy_check_mark: ]

▣▣□ Phase 2 of 3: Installation
Installing EPEL release package [ :heavy_check_mark: ]
Enabling PowerTools package repository [ :heavy_check_mark: ]
Installing dependencies and system packages [ :heavy_check_mark: ]
Installing Virtualmin and all related packages [ :heavy_check_mark: ]
Cleaning up software repo metadata [ :heavy_check_mark: ]
Installing updates to Virtualmin-related packages [ :heavy_check_mark: ]

▣▣▣ Phase 3 of 3: Configuration
[1/23] Configuring AWStats [ :heavy_check_mark: ]
[2/23] Configuring Bind [ :heavy_check_mark: ]
[3/23] Configuring ClamAV [ :heavy_check_mark: ]
[4/23] Configuring Dovecot [ :heavy_check_mark: ]
[5/23] Configuring Firewalld [ :heavy_check_mark: ]
[6/23] Configuring MySQL [ :heavy_check_mark: ]
[7/23] Configuring NTP [ :heavy_check_mark: ]
[8/23] Configuring Net [ :heavy_check_mark: ]
[9/23] Configuring Nginx [ :heavy_check_mark: ]
[10/23] Configuring ProFTPd [ :heavy_check_mark: ]
[11/23] Configuring Procmail [ :heavy_check_mark: ]
[12/23] Configuring Quotas
The filesystem / could not be remounted with quotas enabled.
You will need to reboot your system to enable quotas. [ :warning: ]
[13/23] Configuring SASL [ :heavy_check_mark: ]
[14/23] Configuring Shells [ :heavy_check_mark: ]
[15/23] Configuring SpamAssassin [ :heavy_check_mark: ]
[16/23] Configuring Status [ :heavy_check_mark: ]
[17/23] Configuring Upgrade [ :heavy_check_mark: ]
[18/23] Configuring Usermin [ :heavy_check_mark: ]
[19/23] Configuring Webalizer [ :heavy_check_mark: ]
[20/23] Configuring Webmin [ :heavy_check_mark: ]
[21/23] Configuring Fail2banFirewalld [ :heavy_check_mark: ]
[22/23] Configuring Postfix [ :heavy_check_mark: ]
[23/23] Configuring Virtualmin [ :heavy_check_mark: ]
▣▣▣ Cleaning up

[SUCCESS] Installation Complete!
[SUCCESS] If there were no errors above, Virtualmin should be ready
[SUCCESS] to configure at https://xxxxxxxxxxxxxxxxxxxxxxxx:10000 (or https://xxxxxxxxxxxxxx:10000).
[SUCCESS] You’ll receive a security warning in your browser on your first visit.
Connect whith chrome
´Post installation wizard

When you press the “next” button, it indicates that you are going to start doing something … but it does not change the screen

systemctl status webmin.service
● webmin.service - LSB: web-based administration interface for Unix systems
Loaded: loaded (/etc/rc.d/init.d/webmin; generated)
Active: failed (Result: exit-code) since Sun 2020-10-25 08:08:09 UTC; 25s ago
Docs: man:systemd-sysv-generator(8)
Process: 34767 ExecStart=/etc/rc.d/init.d/webmin start (code=exited, status=25)

Oct 25 08:08:09 vps-c2f862bd.vps.ovh.net systemd[1]: Starting LSB: web-based administration interface for Unix systems…
Oct 25 08:08:09 vps-c2f862bd.vps.ovh.net systemd[1]: webmin.service: Control process exited, code=exited status=25
Oct 25 08:08:09 vps-c2f862bd.vps.ovh.net systemd[1]: webmin.service: Failed with result ‘exit-code’.
Oct 25 08:08:09 vps-c2f862bd.vps.ovh.net systemd[1]: Failed to start LSB: web-based administration interface for Unix systems.
Later, I reboot but the behavior of the post-install is the same
creates a virtual server without problems, but hangs again when trying to create a subserver
When creating the second virtual server, it also hangs


[2020-10-25 07:55:24 UTC] [DEBUG] Operating system name: CentOS
[2020-10-25 07:55:24 UTC] [DEBUG] Operating system version: 8.2.2004
[2020-10-25 07:55:24 UTC] [DEBUG] Operating system type: centos
[2020-10-25 07:55:24 UTC] [DEBUG] Operating system major: 8
[2020-10-25 07:55:24 UTC] [DEBUG] Configuring package manager for CentOS 8.2.2004…
[2020-10-25 07:55:24 UTC] [DEBUG] Disabling SELinux during installation…
[2020-10-25 07:55:24 UTC] [DEBUG] setenforce 0 failed: 1

[2020-10-25 07:58:47 UTC] [SUCCESS] If there were no errors above, Virtualmin should be ready

Somehow Webmin isn’t able to restart. I thought we’d fixed that ages ago (or rather worked around it, because the “fix” is ugly, but it works).

@Ilia do you know of remaining Webmin restart issues on CentOS 8?

I’m rolling a new Webmin version today, maybe it has additional fixes in that area.

Also, I think if you kill -9 the Webmin process and restart it from the command line it’ll sort this out (at least until the next time it gets into this zombie state).

Joe, the restart issue for CentOS 8 supposed to be fully fixed with Webmin 1.960.

Besides, there is no more “dirty” restart from UI. Jamie had to change it, as Webmin processes was killed.

The best workaround for now, is manually restart Webmin on the second terminal tab, right after it was installed (in the middle of Virtualmin installation).


Note: The script above can perform aggressive, non-graceful restart, if needed.

1 Like

Excuse me, but since webmin was not running in the case I indicated, and it gave an error when starting, I rebooted the machine, but even so, after the reboot, and after a reinstallation, Virtualmin continues to hang when starting the post-installation, or when wanting to create a subdomain, …
Reproducing it is very easy for me: I install centos 8 on an OVH machine, install virtualmin, with wget, and it doesn’t matter if I restart, the problem is mounted.

Is this how you’re doing it (VPS)?

Do you pick Distribution only or Distribution with application?



While I am not running any Virtual Machines yet, I have Virtualmin and Webmin running on Centos 8 and the basic configuration has no issues that I am aware of. Centos 8 being the Host os.

I am not sure what you are doing on top of that but I figured I’ll pitch in what I can.

I must say that theirs Virtualmin distributed image works just fine:

Well, yesterday I could not find an image of Centos8 and virtualmin, but after your comment, I have found it and am installing it. However, the problem is that I wanted to have LEMP and not LAMP. Then I will try to change Apache to NGinx.
Thanks for the support.

What exactly doesn’t work on Post-Installation Wizard? Installations steps finished with no issues, as I can tell?

You can manually restart Webmin and try again:


I just reinstalled the vps with an OVH image that is Centos 8 + Virtualmin … and nothing has changed. Everything may be installed fine … but when starting virtualmin, it doesn’t happen from here, the wizard stays on this screen with the gif spinning, which is what it always does to me!

Can you try another browser (Chrome/Firefox)? What is your browser you’re using by the way? Vendor and version?

I could without any problem go with post-install on OVH:

1 Like

I was working with Chrome. I just tried Firefox and it lets me in. I’m going to try to install everything and I’ll tell you something Thank you, and I’m sorry for not having come up with something so elementary

Everything is correct, congratulations on the improvements that I am seeing in this version, and I reiterate my excuses for the time that I have lost you.

Possibly, Chrome has some extensions installed that are causing issues. Chrome is best supported overall. I am pretty sure those issues are caused by one of the installed extensions. Also, make sure that the latest Chrome version 86 is installed.

Everything is correct, congratulations on the improvements that I am seeing in this version, and I reiterate my excuses for the time that I have lost you.

No problem.