Https website unreachable

OS type and version Ubuntu 20.04.6
Virtualmin version Virtualmin 7.9.0

Hi all,

ok, here we go. I installed virtualmin on a vps with the above versions. domain is pointing to it. I can access it on port 10000 just fine.

I registred with namecheap and created 2 nameservers there, and also set it up at virtualmin to act as my own personal nameservers. Seems to work.

Then I installed a virtual server package with the domain Working fine.

One of the reasons that I decided to use my own nameservers (next to it being more professional) is that I received _acme-challenge errors with Lets encrypt. After getting my domainservers at virtualmin, getting certificates is just working fine.
So, I got an SSH certificate on decentraalinternetnl and

Here I used the build in script to test installing a wordpress website. Also that worked. But when clicking the link to the new website, a PR_END_OF_FILE_ERROR error appears.

Looking on the forum here and on the internet, I get about a zillion different reasons why this could be (some of which I tried and checked), but I’m far too much of a newbe to understand. I need sesamestreet-type explanations :slight_smile:
Can anyone help me out here?

Which browser are you using?
Which antivirus?
I think this may be something wrong with the certificate (chaining perhaps). I think it may be a recent problem.

Fix this before worrying about the http / SSL issues

Have you finish the Virtualmin Wizard? Perhaps runs this again.

The other thing I would of recommended was to have at least one virtual server configured, but I think you have this.

I tried both Firefox and Brave.

I normally do not have these issues on my regular VPS running Direct Admin or so, but this is a new experiment indeed. Although I managaed to get the Lets Encrypt certificate, I’m very much willing to believe something is still wrong in the setup

I know that works fine. An installation script like WP creates an https as it always does. In this case it’s not reachable. It’s not WP related, it’s https related.

Sorry, just saw your other questions. yes, this is already another virtual server.
Thanks, I could try to run the wizard again

The build script, what does this do? Is it createing the SSL and other system things or is it purely for installing WordPress. You should let Virtualmin handle all of the System stuff or at the very least use the Virtualmin API commands and not ‘RAW’ linux commands.

Lastly try running: Virtualmin → system settings → Re-Check Configuration

I don’t get that response on Chrome. (Windows)
I get

so the cert seems to be at fault

Well, somehow it was able to obtain it.

Any suggestions on what to check? This is far outside of my league…

No errors there

  • IP =
  • rDNS of =
  • points to your Lineagos Router at home
  • Your name servers, I am curious how you set 2 of these up on Virtualmin
  • have you enabled Wildcards for your Lets encrypt Certificates? If your DNS is not correct this could cause an issue.

I think SSL is not the issue, but apache.
You done something to make apache point here /var/www/html/index.html

Virtualmin should configure apache as below

Did you do a standard virtualmin install as per docs

maybe not important — I see that both and point to — is that IP going to your home, or to Namecheap? As I am confused a bit when you wrote

created 2 nameservers there, and also set it up at virtualmin to act as my own personal nameservers.

Just because you tell Virtualmin to create and handle DNS locally does not mean the outside world knows about it too :grinning:

Thank you Stefan, yes, that’s exactly what I used. I have not manually edited any files.

Hi Verne,

Both the manual of virtualmin as well as the manual of namecheap support eachother saying you can use virtualmin as nameservers, when you register them at namecheap.
So I followed this description:

After registration a while later I was able to set them up here:

When I do i search on the TAB Advanced DNS I see it points to the virtualmin server at …27.27

I actually ending up using the support chat from Namecheap whuch were kind enough te help me out although I had slight doubts. Anyway, I figurered they would know.

Edit; below the settings in virtualmin, this is how I read it…

Your system seems to be ignoring the virtualmin directives. You could go through the apache config and see where it points to /var/www/html/index.html

When you ran the install script and used wizard did you use a FQDN like server

Also when a use your IP in the browser I see this eventually,

You have install virtualmin on a clean OS?

Take luci/lineageos gui off port 80 http and 443 Https

Thank you! Done

Just started a clean install again. Weirdly enough, when creating the first virtual server it wants to use as it’s external address, which is the router of all those servers, in stead of the actual vm at …27.27. No idea why.