HTTPS not loanding although works fine in HTTP

OS type and version: Debian Linux 10
Webmin version: 1.941
Virtualmin version: 6.08
Related products version: SSL

Having trouble loading https website although http works fine. Loaded new cert and checked apache vhost seems set up fine. All options in virtualmin are on where I can find them. turned SSLUseStapling off so not getting that error any longer but still unable to load any part of website with wildcard ssl from godaddy. Not even showing up as error ssl acts as if it doesn’t even recognize it. Not sure if some setting is overriding the vhost ( under apache2. No error logs coming up at this point either. website is

Could be a number of things, but it seems like your server isn’t responding on port 443 at all.

This typically means that either you don’t have all the options on in Virtualmin that you think you do (remember that “SSL Website” needs to be checked in the Server settings), or perhaps your hosting company or server firewall is blocking port 443.

1 Like

when I run netstat -tulpn | grep :443 it gives me:
tcp6 0 0 ::::443 :::* LISTEN 651/apache2
I’m not seeing any tcp listen which would be for tcp 4
Port forwarding is correct. What other diagnostics can be done to see where the data is blocked. Check “SSL Website” checked is good as well. What would cause the port to not being used but for tcp6?
Webmin seems to work fine in https… so wondering why the websites won’t show them under that port.

Is SSL Apache module enabled on Servers ⇾ Apache Webserver: Configure Apache Modules page?

Besides, double check whether Apache listens on port 443 for IPv4 addresses. What about created VirtualHosts found in /etc/apache2/sites-available Apache config files – do they have :443 for an IPv4 address configured to listen on?

Also, have a look at - Server Configuration ⇾ Change IP Address page.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.