Https force redirect

hello I have install let’s encrypt ssl certificate for my domain which is working fine. But when I enter my domain without https, browser showed website is not safe.
Is there any way to force redirect to https without entering https? please help!

I have access to both webmin/virtual min panel for my domain.

  1. virtualmin>Virtual serve>Apache SSL website is enabled

  1. The goto Virtualmin>Server Configuration>Website Options>"Redirect all requests to SSL site? (set to yes)

I think it is probably even possible to do a website redirect…Virtualmin>Server Configuration>website redirects>Add new website redirect (however i think this would be mainly if you wanted to redirect a completely different website rather than just http to https)

hope this solves your problem.

1 Like

Thank you so much for your explanation :smiley: I can’t even find that on youtube xD. now my website is fully https even I enter just the domain name. Really thanks for your time on this :smiley:

you are very welcome.

1 Like

I’ve always done this via .htaccess in the same direction as the index.* for Apache, just ran across this setting earlier today and just now read this thread.

Any harm in having both, that is, the .htaccess AND using the above setting? Not looking for any “redundancy” but if I can do it at the server level, I won’t have to use the .htaccess method.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.