Htaccess: Options not allowed here subserver

SYSTEM INFORMATION
OS type and version Linux Debian 10
Webserver Apaache2
Virtualmin version 7.1 Masternode

Hello Virtualmin community members

I just installed virtualmin for the first time, as i am not a expert cli user, i find it awesome, I was able to setup my main domain and its subservers and installed few of my applications without any issues.

However on one of my subservers I have a internal server error when i visite the page.
looking in the apache logs for this specific server i have following error,

htaccess: Options not allowed here

My vhost looks like this
SuexecUserGroup “#1001” “#1001
ServerName socialproof.jv-net.digital
ServerAlias www.socialproof.jv-net.digital
ServerAlias mail.socialproof.jv-net.digital
ServerAlias webmail.socialproof.jv-net.digital
ServerAlias admin.socialproof.jv-net.digital
ServerAlias autoconfig.socialproof.jv-net.digital
ServerAlias autodiscover.socialproof.jv-net.digital
DocumentRoot /home/jvnetdigital/domains/socialproof.jv-net.digital/public_html
ErrorLog /var/log/virtualmin/socialproof.jv-net.digital_error_log
CustomLog /var/log/virtualmin/socialproof.jv-net.digital_access_log combined
ScriptAlias /cgi-bin/ /home/jvnetdigital/domains/socialproof.jv-net.digital/cgi-bin/
ScriptAlias /awstats/ /home/jvnetdigital/domains/socialproof.jv-net.digital/cgi-bin/
ScriptAlias /AutoDiscover/AutoDiscover.xml /home/jvnetdigital/domains/socialproof.jv-net.digital/cgi-bin/autoconfig.cgi
ScriptAlias /Autodiscover/Autodiscover.xml /home/jvnetdigital/domains/socialproof.jv-net.digital/cgi-bin/autoconfig.cgi
ScriptAlias /autodiscover/autodiscover.xml /home/jvnetdigital/domains/socialproof.jv-net.digital/cgi-bin/autoconfig.cgi
DirectoryIndex index.php index.php4 index.php5 index.htm index.html
<Directory /home/jvnetdigital/domains/socialproof.jv-net.digital/public_html>
Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted
AddType application/x-httpd-php .php
AddHandler fcgid-script .php
AddHandler fcgid-script .php7.3
AddHandler fcgid-script .php7.4
AddHandler fcgid-script .php8.0
AddHandler fcgid-script .php8.1
FCGIWrapper /home/jvnetdigital/domains/socialproof.jv-net.digital/fcgi-bin/php7.3.fcgi .php7.3
FCGIWrapper /home/jvnetdigital/domains/socialproof.jv-net.digital/fcgi-bin/php7.4.fcgi .php7.4
FCGIWrapper /home/jvnetdigital/domains/socialproof.jv-net.digital/fcgi-bin/php8.0.fcgi .php8.0
FCGIWrapper /home/jvnetdigital/domains/socialproof.jv-net.digital/fcgi-bin/php8.1.fcgi .php8.1
FCGIWrapper /home/jvnetdigital/domains/socialproof.jv-net.digital/fcgi-bin/php8.0.fcgi .php

<Directory /home/jvnetdigital/domains/socialproof.jv-net.digital/cgi-bin>
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted

RewriteEngine on
RewriteCond %{HTTP_HOST} =webmail.socialproof.jv-net.digital
RewriteRule ^(?!/.well-known)(.) https://socialproof.jv-net.digital:20000/ [R]
RewriteCond %{HTTP_HOST} =admin.socialproof.jv-net.digital
RewriteRule ^(?!/.well-known)(.
) https://socialproof.jv-net.digital:10000/ [R]
RemoveHandler .php
RemoveHandler .php7.3
RemoveHandler .php7.4
RemoveHandler .php8.0
RemoveHandler .php8.1
FcgidMaxRequestLen 1073741824

AuthName “socialproof.jv-net.digital statistics”
AuthType Basic
AuthUserFile /home/jvnetdigital/domains/socialproof.jv-net.digital/.awstats-htpasswd
require valid-user

Alias /dav /home/jvnetdigital/domains/socialproof.jv-net.digital/public_html
<Location /dav>
DAV on
AuthType Basic
AuthName “socialproof.jv-net.digital”
AuthUserFile /home/jvnetdigital/domains/socialproof.jv-net.digital/etc/dav.digest.passwd
Require valid-user
ForceType text/plain
Satisfy All
RemoveHandler .php
RemoveHandler .php7.3
RemoveHandler .php7.4
RemoveHandler .php8.0
RemoveHandler .php8.1
RewriteEngine off

Redirect /mail/config-v1.1.xml /cgi-bin/autoconfig.cgi
Redirect /.well-known/autoconfig/mail/config-v1.1.xml /cgi-bin/autoconfig.cgi

And the htaccess file looks as follows:

Options All -Indexes

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule ^(.+)$ index.php?altum=$1 [QSA,L]

Order allow,deny Deny from all ExpiresActive On

Images

ExpiresByType image/jpeg “access plus 1 year”
ExpiresByType image/gif “access plus 1 year”
ExpiresByType image/png “access plus 1 year”
ExpiresByType image/webp “access plus 1 year”
ExpiresByType image/svg+xml “access plus 1 year”
ExpiresByType image/x-icon “access plus 1 year”

CSS, JavaScript

ExpiresByType text/css “access plus 1 month”
ExpiresByType text/javascript “access plus 1 month”
ExpiresByType application/javascript “access plus 1 month”

Any idea on how i can solve this issue without changes to htaccess as it has been given by the developper, the script worked just fine on namecheap so i suppose it is some apache conf error in my vhost conf

thanks for your reply’s

John

in which directory is .htaccess located?
if it’s in public_html/ then,

remove this from .htaccess, it’s already in apache vhost config :

otherwise you have to use
AllowOverride … +Options
in vhost particular directory config to allow options in that htaccess.