How to skip 1 database or table during all databases backup?

OS type and version alma 8
Webmin version 2.021

Is there a way to skip 1 database during the backup off all datbases?

Or skip a table (a view to be precise)?

I have tried adding


to the “Add custom parameters to backup command?” field

but then the error still is

"mysqldump failed :

mysqldump: Got error: 1356: “View ‘db_com_trunk.link_alternate_from_page_id_list’ references invalid table(s) or column(s) or function(s) or definer/invoker of view lack rights to use them” when using LOCK TABLES"

thank you.

I have learned that this does work, but there are 2 tables that need to be skipped and then it doesn’t work.

When adding
–ignore-table=db_com_trunk.link_alternate_from_page_id –ignore-table=db_com_trunk.link_alternate_from_page_id_link

Then the second is ignored and the backup fails. You do need to add it multiple times to skip multiple tables.
This is a bug in the mysql/mariadb backup procedure.

Thank you.

Any update on this bug?

How is this a webmin bug, your using a mysqld command.

Because the op is adding an option to the backup command i guess

Does it work ok using the dump command?

yes, it does. and that is the bug / problem.

The manual says:

“To ignore multiple tables, use this option multiple times.”

When you add it multiple times to the “Add custom parameters to backup command?” field on the backup form, then the first is processed and the second is ignored or skipped. Perhaps it was designed this way because most parameters can only occur once.

When adding
–ignore-table=db_com_trunk.link_alternate_from_page_id –ignore-table=db_com_trunk.link_alternate_from_page_id_link

as stated in the manual then the second given an error. the same error the first gives when no option are added, and when ii switch the ignore statements then the other gives the error. That how i tested what is wrong, and the bug is that the second (and perhaps more) –ignore-table= is skipped.


Right, sounds like a bug for @Jamie unless the format is different using that page.
Have you created a schedule? I think it would create a cron, then you could tell from that what command its using.
P.S I also noticed it backups all databases, do you have more then one database?

Yes, it runs on a scheduele (that makes a cron) and mail only on errors. I get a mail with the error as in the first posting. That is how i discovered that 1 view gets ignored and the one in the second parameter is not.

I have tried every possible combination:

  • switching the parameters
  • gz / don’t gz
  • Backup within a transaction? yes/no
  • Dump rows one at a time? yes/no

The cron command is pretty meaningless for debugging

/etc/webmin/mysql/ --all

I have tried backuping up this database on its own, but with the same result. as far as i see: every backup is done with the same code.

single backup cron is

/etc/webmin/mysql/ db_com_trunk


Hopefully jamie will have a answer for you.

Any news on this yet?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

This feature is already available in Virtualmin. You should check for Administration Options ⇾ Excluded Directories and DBs page.