How to set virtualmin user for ssh access?

I used to go into System Customization/Custom Shells and enable bash for Email, FTP and SSH and set it to default, clearing the default for whatever other shell might be enabled for admin. I provisioned a new system recently and did the same thing version on 4.18.gpl. But the dropdown box for Other User Permissions includes Email only, Email and FTP, and Email and SCP. No SSH access.

Anyway how can I add a user with ssh access now?


I attached three screen shots but when I look at the post I don’t see them.


Bump. Still no options for SSH. Any solutions?

I enabled SCP on a user the other day and SSH worked OK. Have you tried that?

Or what if you go to Virtualmin -> System Customization -> Custom Shells, then enabled “Custom shells below” then choose the ones you want to offer, you can offer SSH and FTP for example.

I’ve tried that, however when you login to ssh, it doesn’t give you access to shell.

This worked for me! Thank you!! I’ve tried this before as well, but didn’t put a check mark under the mailbox column. I decided to try it again with the mailbox and it popped up. Thank you!

Take a look at my original post. I have bash enabled and default but it doesn’t give me a bash login, Looking at /etc/passwd I see the shell is set to /usr/bin/scponly

jim.xxxx:x:1005:1000:Jim Lynch:/home/fxxxx/homes/jim:/usr/bin/scponly

What if you go to:
Webmin -> System -> Users -> your_user

Then choose the shell in there? I think I had to do that the other day too to get one enabled. Not the best approach considering you should be able to choose it in Virtualmin users, but I think that fixed it for me.

In the custom shells, you have to check the mailbox (at least thats what did it for me). Its the second check box after admin. Once I clicked on that and hit save, the ssh option popped up for the users.