How to set up webmail


im not sure exactly how webmail works in webmin/usermin. We have setup the server to allow pop3 logins of the form "user@domain.tld"

Now we want to enable webmail access, where the users .

My questions are:

  1. what is the url of the webmail interface?
  2. if possible, how/where are the webmail options configured?
  3. Will users be able enter their username in the same form as above when logging in to webmail?

Just get the user who wants to retrieve mail to go to:

Sorry I can’t answer your question regarding the specificity of where to click what. I am using Virtualmin Pro, so wouldn’t have a clue how the Virtualmin GPL (free) user interface looks like. From what I gather, Virtualmin Pro is much easier to use than Virtualmin GPL.

Virtualmin Pro is still under Early Adopter (EA) period so licence fee is cheap. Buy yourself a copy of VMpro while it is cheap. Joe said your licence will be extended by 1 year if you buy during the EA period.

By the way, I am not Virtualmin’s chief indian for sales and marketing. I am only a happy customer.

Your default "webmail" would be Usermin and you would typically login at


logging in then, in the same form, user@domain.tld


ooops, sorry AH, missed your post. Sleeping on the job here ;-0

Hey guys,

thanks for the info. we are actually using the pro version of vmin.

I can get into usermin without a problem. Thereafter when i click the "read mail" link i get a form asking me to login using an account that has access to the IMAP server.

i enter the same details there (i.e. username@domain.tld with the same password i used to get into usermin) but login fails and gives me:

Failed to connect to localhost:143 : Connection refused

i know we have setup dovecot to serve both pop3 and imap protocols, and these are both working from mail clients.

any ideas?

Did you try to log in to Usermin with username other than root?

All other users other than root should work with Usermin’s mail function.


root can read mail via virtualmin ( mydomain:10000 )

> Webmin] Servers] Read Mail

You didn’t say what mail server you’re running.

Go into the usermin configuration then click on the usermin config mod, choose readmail module and make sure the type and path are correct.

Hi all, fixed it!

Dan Long - i used your suggestion to check the readmail module configuration.

The "Mail storage format for Inbox" setting was set to "remote imap server". i changed this to "Qmail style directory (Maildir)" and this worked perfectly.

No second login form coming up anymore when the user clicks "read mail"

Thanks for all the suggestions guys.