How to set CPU & Memory limits for Virtual Servers (PRO)?

OS type and version Ubuntu 20.04
Virtualmin version 6.17-3 Pro unlimited

Hi there!

I just purchased the Pro version of Virtualmin and based on Googling was hoping to be able to limit user’s CPU and Memory usage. I can’t seem to find any of the options, so my question is… where can I find the options to limit how much CPU & Memory each Virtualmin user can consume?

Ping @staff


This can be found on - Administration Options ⇾ Edit Resource Limits: Resource Limits page.

If you do not see this menu entry, please clearing cache from right side slider (cog button with dashboard tab) or using theme configuration page.

Thanks @Ilia . I already did that before submitting the question. I don’t seem to have “Edit Resource Limits” -option under the Administration Options, no even after clearing the cache.


Is there anything else I should / could check in order to activate the feature?

Edit: obvisously also activated the pro licence prior to clearing the cache.

In order to have this feature displayed:

  1. You need to be a master admin
  2. Your OS type should be set correctly as linux on Webmin config (cat /etc/webmin/config | grep os_type)
  3. There should be a file on your system called /etc/security/limits.conf, meaning the package libpam-modules must be installed
  4. You must be able to edit a domain and a domain must have a correspondent unix user (can be checked in a domains configs under /etc/webmin/virtual-server/domains by finding the domain config file and checking for unix=1 option).

All of this is the case of default installation. If you’re missing something try to remember what you have changed manually.

Also check that your Pro install went correctly. Check that you have a file edit_res.cgi under /usr/share/webmin/virtual-server/pro directory.

Ok, thanks! The last part revealed I didn’t complete the upgrade process. I thought it would be enough just to add the licence via terminal. Googled a bit more and found that I had to run the upgrade process via Virtualmin admin!

All working now, thanks for the help @Ilia :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.