How to manage existing let's encrypt SSL certificates?

OS type and version Linux Ubuntu 20.04.5
Webmin version 1.999
Virtualmin version 7.1-1
Related packages SUGGESTED

I installed virtualmin on my Linux Ubuntu 20.04 web server, and I use it to host and manage virtual web servers for each of my domains (which domains are hosted by an external provider).
When creating my first web servers, the template created let’s encrypt SSL certificates. But the server was never able to renew it each time, although virtualmin template had presumably automatically scheduled renewing tasks at creation time.
So, after a while (90 days roughly), the https corresponding host couldn’t display the web pages of the associated domains, with hard-to-decipher error messages. It was neither possible to delete the let’s encrypt certificate nor to manage renewing scheduled tasks.
It could seem to be a very infortunate impossibility of the virtualmin application which really complicates the management of virtual servers in virtualmin. Any suggestion, remark or advice to solve this issue, preferably within the virtualmin environnement, would be welcomed.

Why does it fail to renew?

Error message (let’s encrypt tab within the SSL certificate management page): “Web based validation failed :
Renewing an existing certificate for and 5 more domains”

HTTPS Web page error message:
“The page is not redirected correctly
An error occurred during a connection to
The cause of this problem may be disabling or refusing cookies.”

I had these problems a couple of months ago. It could have been the DNS BIND service inappropriate configuration, since the DNS BIND was configured as a primary DNS service for the domains whereas the DNS zones were hosted outside my network (DNS provider). It might have confused the let’s encrypt SSL system I suppose.
I tested a lot of sets of configuration parameters, but nothing changed.
Anyway, I don’t really want to deal with that anymore. What I would like to know first is: how to delete/reinitialize the let’s encrypt certificate infrastructure and virtual web servers configuration parameters within virtualmin (in order to be able to ask for a new certificate to let’s encrypt by another way, for instance) ?

Thank you by advance, Pierre Olivier.

I believe if you turn off SSL feature for a domain and then turn it back on, it will remove the Let’s Encrypt configuration.

But, also beware that if Virtualmin isn’t managing your certs, you’ll need to script a solution for all the services you want to use the certs. Virtualmin automatically handles setting up Webmin and Usermin, Dovecot, Postfix (only in very new versions with SNI support), etc. to use your certs for domains that have them. certbot generally only handles the web server.


I had already tried formerly, but i tried again after a last update of virtualmin/webmin just to check if the problem hadn’t been fixed in between. I got exactly the same result: same error messages, same problem (web page redirection jamed, same let’s encrypt configuration, etc.).

Regards, Pierre Olivier.

I meant I turned off the SSL as suggested, and then turned it back on, and it didn’t change neither the result I get when displaying the web pages on the https host, nor the configuration within the virtualmin interface.

regards, Pierre Olivier.