How to manage default SSL cert for hostname

| OS type and version | Debian Linux 12 |
| Webmin version | 2.111 |
| Usermin version | 2.010 |
| Virtualmin version | 7.10.0 Pro |
| Theme version | 21.10 |
| Package updates | All installed packages are up to date |

Hi Guys @staff

I’m going to assume this issue is some throwback from the below thread

I have just installed a fresh copy of virtualmin, and are now left wondering how I manage the default ssl certificate. I used to just be able to choose the host name from the drop down menu > manage virtual server > set up SSL certificate. I was then greeted with both green and yellow buttons where I could copy or remove the default ssl cert to the other services like postfix dovecot mariadb. etc. see below

Now that feature is no longer to be seen, the default host name is no longer in the drop down box and from what I can see I’m now left chasing each service individually copying in the default ssl certificate that was set up to each service.

This is insane, what happened… I’m I missing something or is this a bug from the above hostname mail issue ?


You seem to have created subdomain
Is that what you wanted as all certs will have menia in them

are you asking is I have created the subdomain or are you telling me to now create the subdomain ?

yep, did you want menia. as the virtual server normally you would use just

yep what … which one, ??

my issue is I have never had to create a subdomain of the host name before. Now its no longer there. Is this the new normal or is it a bug ?

That is what I would like an answer to.

Maybe, seen something . Is this on the latest script install?
I’ll do a test, what did you name the server?

do you mean your missing this

my issue is I have never had to create a subdomain of the host name before

No idea what you mean, maybe its just late.

The host default domain is hidden from view by default. You can control this in System Settings ⇾ Virtualmin Configuration: SSL settings by using the Create host default domain with Let’s Encrypt certificate option.

Yes, that is exactly what I mean is missing

Hi @Ilia

Unless I’m missing something that is not exactly the same as we had previously. Yes it creates a ssl cert for the host name but it does not allow me to specify where to use that default hostname ssl. Eg it does not assign it to Usermin nor mariadb I now have to do this manually.

I would like the functionality we had before a button to copy it to the other services.


BTW what does “Yes, and keep visible” mean ?


Also how do I now recreate an hostname ssl after its been done automatically. as I’m not seeing a way once its been done the first time ?

That button was and still is available on the Manage Virtual Server ⇾ Setup SSL Certificate page.

It means it will be shown in the domain dropdown in the left menu and on other pages in the UI.

You don’t need to do it, but you could turn the default domain feature off and then on again using the Create host default domain with Let’s Encrypt certificate option to have it recreated.

Hi Ilia

Ok This is what I was after, it brings everything back. !!!

I probably should have read the tooltip but you know no one really does until its to late.

Given updates and changes should always make life easier for the user not harder, may I make the suggestion that given this new “normal” if a host default domain ssl" is created may I suggest you also copy it to all other servers as the default this way when stupid people like me cant find the button at least it will work as expected out of the box.


I don’t think it’s desirable. Do you mean to Set as Default Services Certificate, right?

@Jamie, what are your thoughts on it – making host default domain serve as default services certificate?

Sure, that’s not a bad idea. If we can create a default domain with a valid SSL cert from Let’s Encrypt, we could also copy that as the default to Postfix / Dovecot / etc…

Yes, thats what we do with all our servers … it makes sense to me

1 Like

Alright, implemented here:

@Ilia @Jamie

Thanks Guys much appreciated

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.