How to integrate VirtualMin SMTP with Mautic step by step?

Hi everyone, I’m new to virtualmin but I’ve been using Mautic + Amazon SES for over 4 years. I discovered that virtualmin offers an unlimited SMTP service for VPS servers, and I wanted to integrate with Mautic but I tried without success.

I already configured all virtualmin installation steps, such as SSL, dns, MX, email address, DKIM, Dmarc, SPF and everything works normally including in my Thunderbird.

I did the test on mail-tester.com by sending the test email and it gave 9.8/10

But when I try to register my SMTP data, Mautic does not provide me with an option field for STARTTLS.

It only gives me the SSL/TLS options that in virtualmin are apparently disabled by default.

Could someone help me with solving this problem? Is there any way to enable port 465 using TLS? Or will I have to migrate from Mautic to another email automation platform?

Note: I looked for a topic similar to this throughout the forum and there is nothing related to the subject. Neither a tutorial on the internet nor on Youtube, so I believe that few people know the real power of Mautic on a VPS server combined with Virtualmin’s SMTP.

SYSTEM INFORMATION
OS type and version Ubuntu 22.0
Webmin version 2.013
Virtualmin version 2.013
Related packages PostFix

No. It is enabled by default, as well.

smtps is on port 465.

Er, wait…you then say this:

It’s enabled by default. But, of course, if you’ve turned it off or if something went wrong during install that went unnoticed, you can turn it on yourself.

Here’s how we do it during installation: Virtualmin-Config/Postfix.pm at 18a39e47050215f5f3008ba5123aa2af2943a715 · virtualmin/Virtualmin-Config · GitHub

Which is just adding lines to the Postfix master.cf file with the same contents as the smtp lines, but also adding the -o smtpd_tls_wrappermode=yes option.

Hello everything is fine? Thanks for answering. However, in the default settings of virtualmin, only this option appears:
image

I released all ports on the firewall, including port 465, but I couldn’t log in to Mautic, the connection was refused by the server. I’ll test again on another smtp form to see if it works.

Look in Webmin->Postfix->Server Processes

There will be one smtps option showing disabled near the top (that’s just the default lines commented out, we don’t touch those during installation), and then one at the bottom of the list that is the line we add and it should show enabled. Or, at least that should be the case, and is on my systems.

Hello, I came back here to post the solution to my problem. Mautic uses SMTP port 25 in PHP to login via TLS/SSL on ports 587/465 and this port 25 is unfortunately blocked on my server as well as other ports.

So I could never login to my SMTP using port 587, “Plain” login type and TLS security. Or vice versa. Thanks in advance for your help. I installed Mautic on the same server as Virtualmin and now it works perfectly. Success to the creators, to you Joe, keep improving this wonderful tool and I wish you and your partners financial success.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.