How to get wildcard SLL to apply automatically to a new subdomain?

**Operating system: centos
**OS version: 8
Hi , im using vps with virtualmin and running wordpress multisite which used subdomains for subsite . Whenever a new subsite creates i need the let’s encrypt wildcard ssl to b applied automatically ,but when I click the wildcard check box in server configuration>ssl > let’s encrypt , there is no change ,my new subsites are still not ssl certified , can anyone tell me how to achieve it

I’m not sure what you mean by ‘there is no change’. Please expand upon this.

You need to point the domain to Virtualmin’s DNS for wildcard SSL to work. Please indicate if you have been able to get wildcard SSL installed on any one of the domains of your multisite setup?

1 Like

May I know how to point dns to virtualmins dns , currently I’m using dns provided by server company.

Ok, let me describe a typical Virtualmin setup WRT the domain name being used.
The Virtualmin server hostname is something like vps.serverdomain.tld
The Virtualmin server DNS is something like ns1.serverdomain.tld and ns2.serverdomain.tld

Now, in your case, the clientdomain.tld should point to ns1.serverdomain.tld and ns2.serverdomain.tld

This will give Virtualmin full control over all DNS records of clientdomain.tld and enable you to get a wildcard SSL certificate from Let’s Encrypt which will be automatically applied to all subdomains that you create for clientdomain.tld in Virtualmin.

Thank you for helping me out, So currently I have pointed my domain to the server companies nameserver and pointing my ip address , now do I need to change the nameservers to virtualmins ? And where can I find the nameserver of vurtualmin .

Yes, this is a requirement. In order for Virtualmin to get a wildcard SSL for a domain from Let’s Encrypt, the domain must point to ns1.serverdomain.tld and ns2.serverdomain.tld i.e. Virtualmi’s name servers.

You had specified the name servers in the Post-Install Wizard when you were installing Virtualmin.

Also, in Virtualmin → Server Configuration → DNS Records

In the screenshot above, and are the name servers that this particular install of Virtualmin has been configured to use.

Thank you ill try this out now

I actually left as it is in nameserver option in post install wizard since I was quiet not sure about it , am I right that I need to re run the post install wizard and keep custom namerservers and change to that in my domain nameservers ,my doubt is can I set my namerserver name using my domain , for example &

You could do that but if it’s on a production server then it is up to you to evaluate the impact that this might have - e.g. with the virtual servers that you may have already created.

No its not on production server , thank you soomuch for helping. ill check this out and get back to you , btw I have another doubt regarding that , do I need to click on skip for resolvability check box when entering custom namerserver ?

Glad I could be of help, Deepak bhai.

Yes, skip check for resolvability but only to work around a propagation issue. You do need the name servers to resolve the way they should, eventually, so you will have to get the concerned domains to work sooner or later.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.