How to get set_time_limit to work?


I notice that PHP set_time_limit doesnt work but I really need it to work on just a specific website. Is it possible to have this done?

Thank you very much!

I’m not sure why using set_time_limit() from within PHP wouldn’t work, unless perhaps PHP is running with safe_mode enabled (which isn’t the default).

However, an alternative might be to edit ~/etc/php.ini, and set the max_execution_time variable for that particular domain.


I think I got the 500 error saying that the code terminated prematurely at 20 secs. I guess that mean set_time_limit is not working. :frowning: I had to increase the IPComm something in php.ini but that’s not idea for me.

Well, you might consider using CGI rather than fcgid, that may solve some of the issue.

If you go into Server Configuration -> Website Options, and change the “PHP script execution mode” to CGI, does it work for you at that point?