How to fix "The uploaded file exceeds the upload_max_filesize directive in php.ini."

OS type and version MacOS Ventura 13.5.2
Virtualmin version I DON’T KNOW
Related packages Default

“The uploaded file exceeds the upload_max_filesize directive in php.ini.” on wordpress

how could i fix this problem ?

Given the information above? You can’t.

edit here

looked on other forums and everyone gave the same advice as you. But our menu looks different. So I don’t know what to do.

Thank you.

there’s no PHP-FPM config on my menu

So, you’re logged is a domain owner user, rather than root. If you don’t have root, your administrator may not have granted you access to configure PHP settings. It’s also possible your administrator has chosen a different PHP execution mode, which may or may not be configurable by end users (e.g. the terrible and deprecated mod_php execution mode can only be configured at the server level, mostly…hopefully that’s not in use, though, as it is insecure and terrible all around).

But, it’s probably a question for your server administrator. We can’t make options available that haven’t been made available to you.

If your server administrator doesn’t know how to grant this ability, it is under Server Templates->Default (or template name, if custom)->PHP Options->Allow editing of PHP configuration

But, it is allowed, by default, I believe…so they seem to know what they’re doing and decided their users should not be able to customize PHP settings (which is reasonable in a low-cost shared hosting environment, where it’s easy for one customer to consume all the resources).

In short: You need to talk to your system administrator. If you are your system administrator, you need to login as root or a root-capable user.

very useful. i’ll inform this to system administrator.
thank you :smiley:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.