How to enable zend cache in ubuntu 14.04


I have installed Virtualmin on a new VPS.
System is Ubuntu 14.04
As I understand Virtualmin uses FCGI as default.
I was looking for tutorial on enabling zendcache which is included by default in PHP 5.5.

The only type of manual I found was similar to this:

meaning that I would have to enable PHP-FPM first or am I wrong?

Please help!


Hmm, I don’t see anything there that suggests you would need PHP-FPM, and it would surprise me if that was a requirement for the Zend Cache to work.

I suspect it’ll work great with any of the PHP Execution Modes supported by Virtualmin. Give that a shot though and let us know how it goes!


Hi Andy,

Thanks for reply.
Well, I tried, but now, I don’t know, if it’s only my localised google page showing strange results or what but all the tutorials I saw, instruct that in order to enabled opcache in Ubuntu 14.04 you have to modify php.ini which is located in /etc/php5/fpm/php.ini

that folder does not exist in my installation.

Two examples of tutorials:

I also don’t know why everybody is writing about fpm if fcgi exist and is in use a lot.

You do NOT need php-fpm to use Opcache. Google is probably spurting these pages out as PHP-FPM is the new thing which everyone is talking about.

Ubuntu is not my OS but…

  1. You need to check you have the module installed, if not then install it.
  2. Enable the module for the site you would like it on.

You will probably have it installed already, it is standard with php55 but this does depend on your packager.

A great way to check the setup that is in place is using an info.php page. It will tell you what php.ini you are using, what modules are loaded,what their settings are and also where they are located.

There is a little info on the php info at:


Thanks for the info.
I created phpinfo.php pasted variables but it opens like a text file instead of showing
php info.

Why on earth would it do that?
In the past Virtualmin worked out of the box with such settings.

Bit odd, this is done automatically by Virtualmin (or webmin, not sure how it is split) automatically.

I am far from being an expert but sounds as though your virtual host conf does not contain the necessary directives. Check point 7 & 8 at .

The relevant file to check for these would be:

Virtualmin > Service > Configure Website > Edit Directives

Probably worth making a note of which file get opened. It is listed above the text box, in the line starting “Use the text box below to manually edit the Apache directives in”

Here you will be looking for the line “AddType application/x-httpd-php .php”

The file you are in gets pulled into the “full” conf file for apache, with each virtual server having it section. You should have the line in each of your virtual servers.

In terms of the LoadModule it will depend on the setup for ubuntu 14 how this is done, there may be sub directories which get scanned and the modules present get loaded, not sure.