How to enable SSH agent forwarding?

SYSTEM INFORMATION
OS type and version Debian12
Webmin version 2.105
Virtualmin version 7.9.0

I’m trying to get SSH agent forwarding to work, specifically in connection with Github.

The key works when I SSH into my Virtual server, i.e. ssh user@hostname and am not prompted for a password. I can git clone from GH to my local machine – that works too.

I cannot, for the life of me, get SSH agent forwarding to work on my server.

I’ve uncommented AllowAgentForwarding yes in /etc/ssh/sshd_config on the remote server.

Followed by

sudo systemctl restart ssh / sudo systemctl restart sshd

In ~/.ssh/config on my local machine, I have:

Host {remote_server_IP}
  ForwardAgent yes

Is there some additional setting I’m not aware of?

Any help is greatly appreciated.

Bumping this

Not really a Virtualmin question. I’m assuming you’ve checked the web for solutions? You haven’t indicated what you see in your logs?

This looks like what your doing.