How to disable mobile theme?

I have had the virtualmin mobile theme installed for some time, and I just got an iPhone and started using it. I quickly decided that the iPhone’s web browser is good enough to not need the mobile theme and I’d rather just use the regular virtualmin interface theme.

So, I deinstalled the mobile theme, but now when I log in I get http authentication and the default Webmin theme, and no virtualmin access. I can log in to other Virtualmin boxes which never had the mobile theme installed, and the interface is fine.

How do I this Virtualmin installation back to the regular default Virtualmin theme, as if I had never installed the mobile theme?


Mobile devices behavior is configurable. Look in Webmin:Webmin:Configuration:Mobile Device Options.

The behavior you’re seeing is Webmin trying to serve the selected mobile theme…but not finding it, and so falling back to the default (the old crufty default).

Just turn off mobile device special treatment, and things will be back to normal.

Worth noting: Jamie got an iPhone a month or two ago, and is working on an iPhone theme at the moment…

Oh, sweet! iPhone theme, good news. Looking forward to that.

Thanks for the help.