How to disable mail greylist?

Dear all,

after last update of virtualmin, I enabled mail greylisting and limited the number of mails. Now mails are stuck on the server and are not delivered to the destination. How can I disable the greylisting function? I could not find it on Postfix configuration page.

Thanks a lot in advance!



That doesn’t sound like an issue with greylisting. Greylisting only adds in a delay to an email arriving to your server, it shouldn’t cause email to be stuck in a queue on your server.

I suspect something else may be going on – you can troubleshoot that by reviewing your email logs, either /var/log/mail.log, or /var/log/maillog. Feel free to post any errors you’re seeing there into the forums here.

If you really wish to disable greylisting though, you can do that in Email Messages -> Email Greylisting.


Another post made today about the new mail rate limiting feature suggests that it is implemented using some greylisting “plugin” named “milter-greylist”? So maybe there is a connection?

Maybe Jamie could elaborate how Virtualmin implements the rate limiting exactly, and whether it’s per user or per IP or so.

The tool milter-greylist is indeed used for rate limiting… it’s not actually used for greylisting though, only it’s rate limiting feature is being used.

The tool being used for greylisting should still be Postgrey, and that should show up in the smtpd_recipient_restrictions line of the

Let us know what you’re seeing in the email logs though, and we can dig into that a bit better.