How to Configure ProFTPD correctly on Ubuntu 16.04

Hi There!

– My System Info

Ubuntu 16.04
Using SSL through LetsEncrypt module
ProFTPD module
Main domain is a WordPress

I know there’re a lot subjects for this issue and I read dozens of documentations but unfortunately nothing of those solutions working with me, I installed virtualmin correctly (I think) I’ll write the commands that I run to make sure it’s ok setup

– Commands

  • sudo apt-get update
  • sudo apt-get dist-upgrade -y
  • This message A new version of /boot/grub/menu.lst is available but the version installed currently has been locally modified appeared ONCE during setup and I chose Install the package maintainer’s version
  • Reboot the system
  • wget -O /root/

Then I create the first virtual server for my main domain and sub domains and request LetsEncrypt certificates and all working very well.

– My Issue with FTP, WordPress and FileZilla

1- I tried to login in FileZilla with Host: but I received the following messages…

Status: Initializing TLS…
Status: Verifying certificate…
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing…
Status: Server sent passive reply with unroutable address. Using server address instead.
Command: MLSD
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

I made some searches and I see this command modprobe ip_conntrack_ftp in {} so I run it and reboot the system but the same messages appear …

2- In my main domain I cannot add new plugin or media file and FTP credentials box appear too (I think it’s related).

Thanks for your help.

Looks like it might be a firewall issue. Try switching between active and passive mode in your FTP client, to see if it still have problems in both modes. If it doesn’t, you know you just need to open up the ephemeral, or high, ports, and it’ll start working in the other mode (I can never remember which is which, but one of them makes a connection back to the client on high ports and so requires them to be open in both directions). And, it may be that your home network router/firewall is misconfigured for dealing with that kind of FTP.

I’m not sure what else might be the issue…we’d need to see the FTP server logs, not the client side of the connection. The client rarely knows why something fails but the server usually does.

Thanks for you reply, I’m not sure I understand very well but I viewed the log file for ProFTPD in { /var/log/proftpd/proftpd.log } But I cannot understand what about Firewall

I tried these steps {} with FileZilla now I can see the directory.

But of course I still cannot add plugins or media in WordPress site.