How to change hostname on usermin login page

OS type and version Ubuntu 22.04
Webmin version 2.021
Usermin version 1.861

I can’t seem to figure out how to change the hostname that shows up on the login page for usermin. Currently it says " You must enter a username and password to login to the server on localhost", but I can’t seem to get localhost to change to something else. I was able to use a custom-lang file to modify the rest of the text though.

What hostname is in the URL that you’re browsing to?


Do you see “localhost” beside your IP address on the “Dashboard” of Virtualmin as well?

On the Virtualmin dashboard it shows the hostname of the system next to the IP address. i.e.

I’m using my own domain to connect, but the reverse-proxy is using localhost:20000. I assumed that’s where that was being generated from, but I figured there would be a way to edit the page so that isn’t there or that you can manually change it to something else. I thought maybe under the “User Interface” configuration under “Usermin Configuration”, but the option there didn’t make a difference for the login page. Thanks for the quick replies.

I found what I was looking for. The configuration option is under “Webmin > Usermin Configuration > Authentication” and you have to check the box next to “Show real hostname instead of name from URL?”.

Strangely, after checking that box and saving the configuration, if you go to the “Authentication” configuration page, it will have unchecked the box, but whatever was changed on the backend is still being applied. In order to uncheck the box (even though it appears to be unchecked) you have to check it, then uncheck it, and then save and that will get you back to the default setting.

Locate the referer line in the config file and update it with the desired hostname. For example, if you want to use as the hostname, you would set the referer line as follows:

Save the changes to the config file and exit the text editor.
Restart the Usermin service to apply the changes.

Using the “referer” option in the config did not have any effect on changing the hostname displayed on the Usermin login page. It still just displayed as localhost.

this should determine whats shown.

I changed to all 4 options, nothing changes, but shows the correct domain for me on rocky9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.