How do I stop cron Job from emailing me ?

Every time my cron jobs run, I get a n email sent to me.

Where do I turn this off ?

I looked in :
WebMin->System->Scheduled Cron Jobs-> Edit Cron Job
but could not see anywhere to turn off the email.

Also I noticed that even though one of my cron jobs was inactive
(red cross) it still go run - is that a known bug ?


What cron job is emailing you, and what’s listed in the email you receive?


at the end of the cmd of the cronjob you can add: >/dev/null 2>&1
a line would look like this: etc/webmin/virtual-server/ >/dev/null 2>&1

The cron jobs that are mailing me are the ones that I set up
via the WebMin control panel.

The contents of the email is empty unless there is an error.
( the error goes in the contents )

The subject line shows which script is being run

Cron focus7@heavyhoster php -q /home/focus7/public_html/auto_remind1.php
Cron focus7@heavyhoster php -q /home/focus7/public_html/auto_remind2.php
Cron focus7@heavyhoster php -q /home/focus7/public_html/auto_warn.php
Cron guru54gt5@heavyhoster php -q /home/guru54gt5/public_html/sys/auto.php #auto-responder

I can not find any option to turn these email notices off.
I am getting several hundred jamming up my inbox most days.

Thanks for helping.

I added that code and I am now waiting until tomorrow to see if the
emails stop getting generated.


This is a pretty SERIOUS PROBLEM

Would be great if someone could let me how to stop the thousandS of emails that are flooding my server when I let the cron jobs

Most of my cron jobs are using this website:
customer service software

and this one:

website traffic

So hopefully these sites will not be too affected by the increase load on the server.

Thanks for that too.

My best regards,and thank´s 1milion times,becouse that eat the cpu resources of an 8gb ram in scond.

first of all, thank you for the answer, but did not work for me

/home/user/folder/script parameter >/dev/null 2>&1

Error: no output created

When i try to start it without >/dev/null 2>&1 it works

/home/user/folder/script parameter

Adding >/dev/null 2>&1 to the end of the CRON job works like a charm.

  • Tim