How do I increase Max Connection Limit?

SYSTEM INFORMATION
OS type and version Debian Linux 10
Webmin version 1.994
Virtualmin version 7.1-1 Pro
Related packages SUGGESTED

in the MariaDB Server Configuration I increase the Maximum number of connections to 500 then 1000 and it seems to not working I can still only get about 150 connections at a time. The other tutorial I found online seems to not be applied to virtualmin since everything is configured in virtualmin.

I am currently running 16gb and 6 cpu. It doesn’t matter if increase the server size to 64 GB memory and 16 cpu. The setting still seems to not be working to increase the max connection limit in webmin.

@smith12654,

You are able to access, and adjust configurations for MariaDB via Virtualmin, however it does NOT control MariaDB. Big Difference.

*** Profesional, Affordable, Tech Support: https://tpnassist.com ***

I don’t know what this means. We use the system package for Mariadb. It uses the default file locations (e.g. /etc/my.cnf and included files).

If you changed it on Webmin / Servers ⇾ MySQL Database Server: MariaDB Server Configuration page it should work, as long as you chosen Save and Restart MariaDB.

You can see what’s active configuration is on Servers ⇾ MySQL Database Server: MariaDB System Variables page, by filtering option by name.

Thank you Ilia! That’s what I did except I pressed save and then restart the server after. I tried it your way and I still get about the same result when I try a load test. But I have been having an issue in my setting and I looked through the forum and didn’t find a solution.

One page load, when I go to the url of the website I host in this server take 100% of my cpu. I think that might be the problem since it shows the configuration is set right in the MariaDB system variable.

How do I diagnose and fix this problem?

It doesn’t matter if I upgrade the server to 16 cpu, one page load always take 100% or more of the available cpu in shared server.

the /usr/share take 96% of the cpu if I leave a page with virtualmin open. I am using php fpm php7.4 currently on a 16GB and 6 cpu

You need to check your logs and find out what’s using all the resources and causing that spike. MariaDB may be running heavy, but something is causing it to run that heavy. That is the issue, not MariaDB.