High Memory & CPU Usage

Hi Everyone,
I have had a recent kernel update on Ubuntu Server 18.04 and it seems to have driven my server crazy. I am getting High CPU on MySQL and Clamav. I have disable email scanning for Clamav within Virtualmin but when using htop it is showing that the email is scanning with it which is overloading my server. Even when i kill the process it keeps coming back. The server is hitting nearly 200% i can’t even keep it on at the moment as the disks are over active and i am getting so many MYSQL and Clamav processes the server is locking up and sites are all down. Any help would be appreciated.

Thanks

Rockyuk

Are you sure you’ve disabled AV scanning for your domains? It sounds like maybe you just switched it from clamdscan (which is a high-memory, low-CPU configuration) to clamscan (which is a very high-memory, very high-CPU configuration) and scanning is still happening.

You can’t “kill” those processes usefully because a new process will be spawned for every new incoming email…resulting in the behavior you’re seeing. Not the only possibility, but the symptoms fit.

Do disable AV scanning you’ll need to do it for all domains. You can do that in bulk, by clicking List Virtual Servers, selecting all servers that have mail, and then clicking Update Selected. From there, you can open the Enabled Features section and disable virus scanning.

Adding clamscan user to clamupdate group brought my cpu load to its normal value.