High disk IO spikes hourly, caused by aptitude

I have a Virtualmin server running on Ubuntu 14.04. I looked at my statistics and notice that almost hourly (actually a little over an hour between) I am getting a huge IO spike. I am on an SSD VPS so the height of the spike is to be expected, but not the frequency. I watched the server around the time it should spike and the processes that came up were apt-get apt-show version and aptitude.

Does Virtualmin/Webmin have some process to check for updates hourly? If so, can this be changed to a lesser frequency?

I looked at my Cron jobs listed in Webmin and do not see anything that fits the bill, but I may be missing it.


Yes, this is Virtualmin’s Security Updates module. It’s kind of convoluted how this gets checked (it is being checked as part of the normal Virtualmin status check, which happens every few minutes…but the Security Updates module caches the package list for an hour, by default, so it would only get run every hour). I believe it’d just be a matter of changing the cache duration in the Security Updates module configuration to some other value…say, 12 hours, or 24 hours, if you wanted a twice-daily, or daily check.

Hey Joe,
Thanks for the feedback, that makes sense. I am not really sure where I could start looking for the cache duration setting, can you give me any pointers on where to start looking?

Browse to the Virtualmin Package Updates module (“security-updates” is the name of the package that provides this module).

You can get there by clicking on the “Virtualmin packages” link in the “Package Updates” section of the System Information page (the first page you see when logging into Virtualmin), or by browsing to Webmin:System:Virtualmin Package Updates. Then click on the “Module Config” link in the top left corner of the content pane.

There is also a new Software Package Updates module in Webmin (which will eventually replace Virtualmin Package Updates, since they replicate functionality), but it is not called automatically in current Virtualmin systems, so can be ignored.

Hi Joe,

I get it. Module Config is the key. I will try changing this to 24 hours and see if that makes a difference in the impact.