HELP! I've messed up the BIND configuration!

OS type and version Ubuntu 18.04
Webmin version 2.001
Virtualmin version 7.2-1 Pro
Related packages SUGGESTED

I’ve been trying to configure nameservers on my webhosting system. The main BIND nameserver was

So I went to the registrar and I created and

I then went to each domain name and created the relationship between the domain and these new ns1 & ns2 names

I then deleted the original nameserver

I also went to the system settings > server template area and changed the primary nameserver from to

I added to the manually configured nameservers

Now when I go to “recheck” the domains I get this error:

Your system has 39.28 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB

Errors were found in your system’s BIND configuration : /var/lib/bind/ ignoring out-of-zone data (, /var/lib/bind/ ignoring out-of-zone data (, /var/lib/bind/ ignoring out-of-zone data (, zone has no NS records, zone not loaded due to errors., _default/ bad zone


How can I fix this so that…
A. It works again!
B. is the primary nameserver

I tried adding the original back into the BIND Configuration but that didn’t work! And then I tried going to the server template area and using the original in the master DNS Server Hostname… that didn’t work either!

Obviously I’m way beyond where I should be with this!!! I look forward to fixing everything and getting it to run correctly!!!

Dan Lewis

I’m pretty sure that the server’s master DNS server should be the hostname. NS1 and NS2 should be additional nameservers. At least that’s how I do it.


Also, did you make A entries for NS1 and NS2?

I created ns1 & ns2 on my domain registrar and “glued” those as the nameservers. They are also in the DNS options as nameservers. Do I need to put them somewhere else too?

I’m in Florida so when the hurricane came through my IP address changed. So when it did I noticed that another of my servers picked up the new external IP address while the server I’m having problems with didn’t change.

Here is the server that did change:

Here is the server I’m having problems with that didn’t change:

Why would one server pick up the external IP change while the other one didn’t?

How can I get the server that didn’t change to recognize the change in IP addresses?

In DNS for the domain itself (because that’s the domain the nameservers you created are on), you need five hostname-related entries:

NS entry for pointing to (assuming that’s the hostname).

NS entry for pointing to

NS entry for pointing to

A entry for pointing to its registered IPV4 address

A entry for pointing to its registered IPV4 address

As for the IP addresses changing, that I have no idea about. Are they dynamically assigned? Because if that’s the case then you need someone with experience running a server on a dynamic address, which I’ve never done.

I’ve just updated the A entries… everything else is there. But all the IP addresses are point to the wrong external IP. Yes, the IP address is dynamically assigned, but the other Virtualmin servers I have running has picked up the address change. I don’t know why this one hasn’t.

Maybe I should reboot it and see what happens…

Dan Lewis

Maybe one of the admins here could help…

Thanks for your information!

1 Like

Unfortunately, I don’t know either; and I make it a general practice not to give advice when I don’t know what I’m talking about. So for that part, you’ll need someone who’s run a Virtualmin server on a dynamic IP address.

A reboot might help if it’s on DHCP. Or not. Like I said, it’s not something I have any experience with. Just make sure you don’t lock yourself out of the server if you decide to try it.

Well I rebooted and the good news is that I’m not locked out! The bad news is that nothing else changed either! I messaged one of the admins here to see if he could help.

Thank you for your assistance!

Dan Lewis

This could use a bump.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.