Help! broken update broke virtualmin...

Hello Friends,

sorry for raising the alarm but I was updating some 30 packages using virtualmin package update module and I think the connection broke, anyway, it hang for like half an hour with no output. After that I tried getting back to the system information page and virtualmin is not loading. I tried rebooting the vps and it does not launch. My websites are only and I can login thru ssh.

Is there anything I can try at the shell? a log file for virtualmin or some kickstart shell program I can launch…

thanks in advance

I would attempt to run a package update from the command line (you don’t specify what distro this is, but one of “yum update” or “apt-get upgrade” will generally do the trick).

Afterwards, try launching Virtualmin:

/etc/init.d/webmin start

And if it doesn’t launch, what shows up in /var/webmin/miniserv.error?


thank you very much. Solved my problem, now I’ve finished the update and things are back to normal.

thanks for the quick reply, this community rocks!