Having trouble with Proftpd start up

OK i have the buttons back on the system info page now… I have the server set to standalone and not inetd.

I still have the issue of virtualmin not seeing proftpd running.

I’ve uninstalled everything and reinstalled once more. This time i noticed some errors in the install.

This is the problem>>>>
I get asked the following question in the install: see **

INFO - Checking for fully qualified hostname…
INFO - Hostname cannot be localhost.localdomain.
**Please enter a fully qualified hostname (for example, virtualmin.com): panel.fourtwelve.co.uk INFO - Hostname OK: fully qualified as panel.fourtwelve.co.uk INFO - Unable to determine IP address of primary interface.
Please enter the name of your primary network interface:

Later in the install this happens>>>>

Setting up proftpd-common (1.2.10-15sarge4) …
Setting up proftpd (1.2.10-15sarge4) …
Starting ProFTPD ftp daemon: - getaddrinfo ‘panel.fourtwelve.co.uk’ error: Name or service not known

  • warning: unable to determine IP address of ‘panel.fourtwelve.co.uk
  • error: no valid servers configured
  • Fatal: error processing configuration file ‘/etc/proftpd.conf’

The problem seems to be that the server doesn’t have a hostname that the install can get an ip address from.

I’m thinking I’ll try using the internal IP address 192.168.XXX.XXX of the server instead of the panel.fourtwelve.co.uk host name and see if that does the trick.

Unless anyone understands how to give the server a valid host name?
What do you think? Any ideas?

i really would like some help…

I think i have found a major issue that would cause problems at start up, looking at your hostname panel.fourtwelve.co.uk this looks fine until you try to contact it, a ping returns an
unknown host, so i thought this might be a dns propogation issue, but a dig on the nameserver for this host reveals that the dns entry for panel.fourtwelve.co.uk is set up wrong

you had a CNAME record with an IP as the alias value, this is wrong.
as a CNAME record can only have another urls as the alias value.

Once this is fixed the record will resolve correctly and your host should resolve correctly as the ftpd comes up.

Hope this helps


Thanks for your help Mike. This was really useful information. The Dns issue in now fixed and the server now has the correct host name. and proftpd.conf now has the host name correct.

However i still get the issue with virtualmin saying that proftpd isn’t running.

Has anyone else had the problem?

Hey Chris,

I believe the issue with Virtualmin is that the default config on Debian (or maybe it’s Ubuntu, I never can recall) is wrong due to Jamie (and my) assumption that Debian and Ubuntu used the same conventions and similar packages when in fact they don’t.

You can fix it by browsing to the Webmin ProFTPd module and correcting the module config to point to the actual proftpd.conf file (in /etc/proftpd.conf on Debian, I believe). This will be fixed in the next Webmin release.

Thanks Joe.

Your are correct. default config on Debian is /etc/proftpd.conf under the webmin proftpd config.

the script currently writes it as /etc/proftpd/proftpd.conf

Anyway that wasn’t my problem.
My problem was that my host config wasn’t correct when i first installed virtualmin. So it didn’t pick up the external IP address and ran from localhost. Proftpd didn’t think much of that.

I have fixed it now. I rebuilt the server with a fresh debian and nothing else. Virtualmin installed first time after that.
Just the tweak needed to the above.

Thanks for your help. I’ll now get on reading the manuals.