Has Cloudmin been discontinued?

SYSTEM INFORMATION
OS type and version Ubuntu Server 22.04
Virtualmin version Not installed

I would like to know if Cloudmin has been discontinued as I don’t see any updates to it and when I install cloud min from the install script from the cloud min website, once installed and navigate to New System Images it only shows images to download up to ubuntu 18.04.

Also if I click the link inside my cloudmin installation to upgrade to pro the link is dead and displays page cannot be found…

Any help would be appreciated, thanks.

@jhorrocks,

It’s not discontinued, though compared to Virtualmin it is lower priority. If you are experiencing a bug, definitely let @staff know so the matter can be addressed.

*** Professional, Affordable, Trusted Technical Assistance – tpnAssist.com ***

Thanks for the quick response.

Even if I try to get image from Stacklet from the Import new system image, that fails also as their ftp site doesn’t exist anymore.

What I am trying to do is setup a new DELL Server and take out my existing DELL R630 and want to use Cloudmin for docker (Pro version) but don’t know how it works with docker, as I cannot purchase the license and no information on cloudmin docker support that I can find so I cannot test (hence my question is cloudmin obsolete).

Currently in my datacenter I have a DELL R630 running ubuntu server 16.04 with Webmin for easy administration of the server and also Cloudmin software to host KVM’s.

I currently have 3 KVM Virtual Images run by Cloudmin each running ubuntu server 16.04 and all have their own individual IP address

DELL R630 Host Server x.x.x.102
|
|_ Kvm 1
| |_ IP x.x.x.103
| |_ Apache2
| |_ Mysql
| |_ Php website
|
|_ Kvm 2
| |_ IP x.x.x.104
| |_ Nginx
| |_ Mysql
| |_ ASPNETCORE website
|
|_ Kvm 3
| |_ IP x.x.x.105
| |_ Apache2
| |_ Mysql
| |_ Php website

All runs fine but I am going to be purchasing a new DELL server and looking at installing either cloudmin pro with docker images or install portainer and convert all my current websites into docker and running each image inside portainer, so my questions are:

1 - is Cloudmin still a viable option to run KVM’s with ubuntu 22.04 server installed?

2 - How does the Cloudmin Pro version run docker images, does it have an admin interface like Portainer that I can bring up stacks etc… or is it just able to run a pre built docker image that has portainer inside the docker image?

Any help would be appreciated as I am new to docker but a long time user of both Virtualmin and Cloudmin so any tips/tricks or pointers in the right direction would be greatly appreciated.

I’m in a similar position (although use RHEL), as for me Cloudmin works almost brilliantly, but has several issues that are ongoing.

Last time I checked, the docker functionality was broken. A side issue is that RHEL 8+ dropped Docker in favour of Podman (although Podman can run Docker scripts).

Cloudmin on bare metal is currently only supported up to RHEL 7. This means that RHEL 9 as a guest is not supported, which is problematic as we move to a PHP 8 world. I’m not sure if Ubuntu 22.04 is supported.

If you want to use install Ubuntu 20+ as a guest, you’ll need to create your own images.

Your point ‘2’ is exactly the functionality that I need, however I am unsure if this is how it works, as I haven’t been able to get it to work :slight_smile:

I really don’t want to switch from Webmin/Cloudmin as I have had great success over the past 6 years with them, I have purchased the pro Virtualmin and cloundmin in the past and no issues with anything. But right now I feel Cloudmin has been dropped/put on the back burner so I am reluctant to setup a new server with the software.

Would be good if there was documentation with screenshots showing the funionality of Cloudmin with docker, that would be greatly appreciated.

Have you tried using any of these? I’m not sure if Cloudmin has cloud-init functionality though, so config may be tricky.

Yes I have tried a couple from this download page, I have tried also building my own from iso image but no matter what I do, after the ubuntu server 22.04 is built, I can view it in the graphical console but cannot connect the network to the host machine.

I have tried setting the network manually in the KVM and also created a bridge in the cloudmin host but just cannot get onto the host network.

This happens on all KVM images greater than 16.04 as my host cloudmin server is 16.04.

I read that from 18.04 onwards it uses a different network (I think netlan).

Which Linux distro and version is the host system running? Also, some hosting providers like Hetzner have unusual setups that make VM networking with Cloudmin difficult…

The host system has been running Ubuntu Server 16.04 LTS and Both webmin and Cloudmin are running the latest available version.

I cannot update the host system from 16.04 upwards as I have many times setup test host servers at the office and tried upgrading from 16.04 to 18.04 upwards and it always fails regarding the vhost and lxd plus then cannot use the network connections to connect from host to guest.

So doing a lot of testing I have found that cloudmin is dead with today’s new ubuntu 22.04 images and anything you want to run on them.

I think the biggest problem comes from the networking structure Netplan and the way the base images are created.

Its a bit sad as I have had many years of using this software without issues up till ubuntu 16.04 but I think from 16.04+ there where major changes and cloudmin never got any attention to keep up with the changes.

Anyone else with the same issues?

Are you using the latest release, 9.7?

Jamie has fixed the issues in networking for RHEL > 8