Grey screen of no-loading death?

I’m locked out the Wedmin web interface on port 10000.

After the login page, the main HTTP request never finishes. It just hangs indefinitely.

Any advice?

I’ve tried upgrading webmin to the latest using the .sh script /usr/share/webmin/ and, although that’s a nuclear approach, it didn’t work!

I’m now on version 2.02104061837 but have had this issue for some months.

I’ve changed login theme using this set of instructions and that doesn’t make any difference either, so I don’t see it as a theme issue?

putty on and reboot. what browser do you use?

you should not be taking advice from something 7 years old.
This forum is where you should ask first.
change back to theme=authentic-theme

From docs

Thanks for your reply.

This effects all browsers, even in incognito, meaning I’m completely locked out of the web interface, which is why I can’t change theme using the GUI; because the issue is that the GUI is utterly non-working.

Have tried rebooting, doing all package updates via terminal, tried using IP instead of hostname to access. No difference.

so you have the default theme back theme=authentic-theme

Yes, the issue survives the theme change. I don’t believe it’s a theme issue.

so this in VM installed using the automatic build?

try this command

Yes, this build was installed on Ubuntu using the manual method 3 years ago:

Your system has 3.77 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB

BIND DNS server is installed 

Mail server Postfix is installed and configured

Postfix is configured to support per-domain outgoing IP addresses

Apache is installed

CGI scripts can be executed using suEXEC

Apache does not support HTTP/2 : Missing Apache mod_http2 module

The following PHP execution modes are available : cgi fcgid fpm

The following PHP versions are available : 7.4.3 (/bin/php-cgi7.4)

The following PHP-FPM versions are available : 7.4.3 (php7.4-fpm)

Webalizer is installed

Apache is configured to host SSL websites

MySQL 8.0.32-0ubuntu0.20.04.2 is installed and running

ProFTPD is installed

Logrotate is installed

SpamAssassin and Procmail are installed and configured for use

Plugin AWStats reporting is installed

Plugin DAV Login is installed

Plugin Protected web directories is installed

Using network interface eth0 for virtual IPs

Default IPv4 address for virtual servers is XXX.XXX.XXX.XXX [redacted]

Quotas are not enabled on the filesystem / which contains home directories under /home and email files under /home. Quota editing has been disabled

All commands needed to create and restore backups are installed

The selected package management and update systems are installed

Chroot jails are available


pm me you login details, see if i can login. If thats ok?

I’m closing this thread and leaving a note.

In the end, for some reason, Virtualmin Webmin was blocking the request from completing because of my IP address; when I changed VPN from VPN Provider A to VPN Provider B, the issue was resolved.

This is an AWS EC2 instance with firewall set to so not sure how that could be the issue.


I was suspecting a firewall issue, fail2ban maybe

Good idea. I stopped the fail2ban server and it made no difference; when reverting to VPN A, the issue was reaggrevated.

Its probably create a firewall rule on your IP, so maybe (I’m not using fail2ban as I switched to ConfigServer Security and Firewall (csf) – ConfigServer Services so I can’t check) stopping it is too late.
check Jails Status and Actions if you IP is in there. Else not sure why.

Good idea:

this in the enabled state? Does temporally disabling firewall allow login?

Either way, disabled/enabled, no difference with fail2ban.

Did you disable FirewallD for a short period, maybe it AWS’s firewall!!
P.S. although that doesn’t make sense as you would not get to the login screen

Thanks for your help! Going to leave it now.

You really can’t solve this one without packet sniffing. Security protocols are sensitive to the way the packets are treated. I’ve seen them fail because of load balancers, especially if a packet has to be split because of size. Security protocols don’t like to see the answer coming from two different sources. No telling what VPN A is doing differently than VPN B.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.