GPG can't edit keys, decrypt e-mail, or encrypt files

OS type and version 22.04.2
Webmin version 2.021
Usermin version 1.861

I set up GPG encryption for a couple of accounts in my Usermin instance to test with and I am unable to get it to function properly.

I created the public/private key pair for two accounts. I imported the public key from each account to the other one. I tried to set the trust settings to trust the key, but the page just loads for a really long time and eventually stops without actually making the change. I tried setting the trust from the CLI, but Usermin doesn’t recognize the change.

I tried sending a test e-mail from one account to the other. It seems to encrypt the e-mail, but the other side is unable to decrypt. I’m thinking this is because it doesn’t trust the key yet, but it could be something else. This is the error I’m getting:

Failed to decrypt message :
created 2023-04-13
“Test User1
gpg: public key decryption failed: Required environment variable not set

I also tried encrypting a file, but that gives me the below error:

Expecting form-data encoding, but got normal encoding

I tried looking at the miniserv logs but they didn’t seem to provide anything beyond what I was already seeing in the browser.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.