OS type and version Ubuntu 20.04
Webmin version 1.999
Virtualmin version 7.1-1
Related packages PHP-FPM

How to use globalblacklist from mitchellkrogza in Virtualmin?
It should affect all domains on the server.

We have been unsuccessful following the instructions here:

Has anyone had success with this?

There are multiple instructions there. Which ones did you follow? Did you get errors? Do you get errors in the logs?

Thanks Joe,
We have followed the instructions for Apache 2.4+
From Step 1 to Step 6.
There we copied the global version to the end of apache2.conf
Step 7 config test. no error.
systemctl reload apache2. no error
No error in the log
Step 8 Testing. Same response if I test with all the different options. So no blocking.
Step 9 Updated to the latest version. No difference.

Do you know if anyone else has managed to get it to work?

Interesting stuff. you did test from a different server?

Try the per-Virtual Host version of the docs. It’s possible (likely even) that something in your Virtual Host is taking precedence.

It could be the solution. I had whitelisted my own ip. Now it’s removed.
I’ll check during the day to see if those blacklisted are gone from the logs.

Thanks Joe,
My whitelisting was the culprit. The setting in apache2.conf was ok.
It should be in the end:

<Location “/”>
# AND-combine with preceding configuration sections
AuthMerging And
# include black list
Include custom.d/globalblacklist.conf

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.