gitweb.cgi not running - output as plaintext

Hello,

I have a fresh install of Ubuntu Server 14.04.2 LTS. I used the install.sh auto install script to setup Virtualmin.
I wanted to enable Git repositories for my domains, so I installed git using:

sudo apt-get install git gitweb
sudo apt-get install webmin-virtualmin-git

I enabled the feature in the server templates and created a virtualserver. The server is accessible and working in terms of PHP, however when I browse to the domain.com/git it redirects to domain.com/git/gitweb.cgi and the contents of that file is displayed as plaintext.

I had an issue in the past which was solved by the specific instructions outlined in this forum post:
https://www.virtualmin.com/node/15716#comment-69000

Deleting the file did not solve the problem.

The domain error log only ever displayed an error related to this when I changed the filename to gitweb.fcgi. When I did this Apache gives a 500 Internal Server Error and this is output to the error log:

[Fri Mar 13 17:07:33.907616 2015] [fcgid:warn] [pid 6438] (104)Connection reset by peer: [client 192.168.1.1:54187] mod_fcgid: error reading data from FastCGI server
[Fri Mar 13 17:07:33.907725 2015] [core:error] [pid 6438] [client 192.168.1.1:54187] End of script output before headers: gitweb.fcgi

In the main Apache error log this is created:

[Fri Mar 13 17:07:33 2015] gitweb.fcgi: defined(@array) is deprecated at gitweb.fcgi line 1193.
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: 	(Maybe you should just omit the defined()?)
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: defined(@array) is deprecated at gitweb.fcgi line 1246.
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: 	(Maybe you should just omit the defined()?)
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: defined(@array) is deprecated at gitweb.fcgi line 1324.
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: 	(Maybe you should just omit the defined()?)
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: defined(@array) is deprecated at gitweb.fcgi line 1376.
[Fri Mar 13 17:07:33 2015] gitweb.fcgi: 	(Maybe you should just omit the defined()?)
Status: 403 Forbidden
Content-Type: text/html; charset=utf-8

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-US" lang="en-US">
<!-- git web interface v264, (C) 2005, Kay Sievers <kay.sievers@vrfy.org>, Christian Gierke <ch@gierke.de> -->
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8"/>
<meta name="robots" content="index, nofollow"/>
<title>git</title>

<link rel="stylesheet" type="text/css" href="gitweb.css"/>
</head>
<body>
<div class="page_header">
<a href="http://www.kernel.org/pub/software/scm/git/docs/" title="git documentation"><img src="?a=git-logo.png" width="72" height="27" alt="git" style="float:right; border-width:0px;"/></a>
<a href="">projects</a> / </div>
<div class="page_body">
<br/><br/>
403 Forbidden - No project found.
<br/>
</div>
<div class="page_footer">
<a href="?a=opml" class="rss_logo">OPML</a>
</div>
</body>
</html>

The suexec log has nothing added but this:

[2015-03-13 17:07:33]: uid: (1001/coryjreid) gid: (1001/coryjreid) cmd: gitweb.fcgi

I am completely stumped here as I’m still a Linux novice. I switched to Ubuntu for updated versions of MySQL/PHP that CentOS does not have. I did at one point attempt to switch back to CentOS but had the same (new) issue. The server is currently running Ubuntu as stated at the beginning.

Any and all help/support/feedback/suggestions greatly appreciated!

I have this problem too… you found any fix?