FTP Problem: Could not write to transfer socket: EPIPE - Local endpoint has been closed

New hosting account with DirectSpace.net Cloud Account VMwareVPS.8, everything was working fine till we got to 69 GB of the 124 GB allocated on hard drive space, then it would only upload a 0-4kb file and stop with this error:

Error: Could not write to transfer socket: EPIPE - Local endpoint has been closed

In the message log I get this:

Feb 8 22:34:32 [host-domain] proftpd[11392]: 69.xxx.xx.xxx (::ffff:204.x.x.x[::ffff:204.x.x.x]) - notice: user [user-name]: aborting transfer: Input/output error

Direct Space said they do not have any limits on FTP, which is what I would think from this error, and although we have plenty of hard drive space left, it seems like that is the issue.

How can I troubleshoot this?

Are there settings in Virturalmin that can do this?

Its on every account I tested; I never changed any FTP setting, or system settings, its running on CentOs 6.2 and php 5.3.3, with all the latest updates.


Are you able to upload files via other means, such as SSH?

FTP is just one of several ways to upload files, so you may want to see if you can create or upload files via some other means, which will troubleshoot whether the issue is related to disk space.


I can do a wget from ssh, on a 20M file no problem, so that narrows it down a little better.

Is there a setting that I should check?

Tried another FTP client called KFTPgrabber, its error message is no more space left on drive

We have 69 GB used of 124 GB yet its telling me I am out of space, why is this?

Is there a quota that is defaulted to a percentage of space, I have them set to Unlimited in the panel for Quota, under edit server.

It seems to be only FTP related.


Well, that’s an odd problem, I’m not really sure what might cause that.

Does that occur when FTP’ing to your server? Or from your server?


Doing an fdisk told the whole story, we have 128gb in the dirve, only 68.3 GB was allocated to the home partition, so we really were out of space, I will write up a requested feature to show partitions so its clear how much space is really available, since currently it shows the whole hard drive, which is not the case at all, its only what is assigned to that partition.

Hi Jeffrey, I’m having this problem on my Mac right now, trying to upload a backup file via ftp, using FileZilla. Unfortunately I’m not techie and I don’t know what an fdisk is, or how to check the partition… Could you please walk me through the steps you took to resolve this problem? Thanks.

Basically the problem was in how the VPS storage space was allocated, only the VPS manager can change the allocation, my hosting techs fixed it, you can not change the container size from inside it, hope that fully explains it, I had forgotten that the OS takes up a lot of space, log files about PHP errors used it all, clearing logs and turning off notices fix that.