Ftp not working. How to fix FTP?

FTP isnt working with Filezilla

Sub-servers 1
FTP users 1
Databases 1
Command: PASV
Response: 227 Entering Passive Mode (142,93,175,58,148,155).
Command: MLSD
Response: 150 Opening BINARY mode data connection for MLSD
Response: 425 Unable to build data connection: Operation not permitted
Error: Failed to retrieve directory listing

In Site Mnager in General section (in Filezilla) set protocol to SFTP. If you haven’t changed the ssh port, leave the port blank or default. Or if you have changed the ssh port, set it as port.
Hopefully helps.

1 Like

Cant find Site Manager or General section.

Edited answer. The site manager is in FileZilla

So my website login i can seperate but cant in ssh cause im using ssh key for root and no user can log in.

Its not needed to do that. From the error message, I think that you enabled SSL fro the FTP.
Put this line into the tls config from proftpd or directly in the main config:

TLSOptions NoSessionReuseRequired

Make sure to restart proftpd after that.

1 Like

How and where is that config i need to edit? This i dont know.

You can access it in the virtualmin panel.
Go to server -> proftpd and then edit the config file directly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.